[Archived] Map glitches while running flash player

posted
Total Posts
10
Topic Starter
Miyazono
Hello guys, so I livestream quite often, or play osu while watching livestreams. In the past few days I started having some weird problems where my game simply freezes during a map and comes back normally a few seconds later. It didn't bother me that much, because it was once every 1 hour or so. But today I started having some really bad-ass problems with this. Freezing once every 30seconds depending on the map.

My thoughts were: welp, maybe my maps are corrupted, let's redownload them or try new maps.

Did that, still freezing. So what I did was running osu from my external HDD. Same thing happened. Moved back to the client on my desktop.

When I got really pissed off because of that, I tried killing chrome out of the blue. My PC can handle basically anything running with osu (specially considering that I livestream for over a year games that demand even more from my CPU eg. WoW or league).

Either way, I killed chrome and the glitches stopped happening. After confirming it, I tried relaunching chrome. It was fine. But then, as soon as I started a livestream @ twitch, my game started freezing again. Killed flash and problem was solved.


Video or screenshot showing the problem:

http://www.twitch.tv/neverendgnv/b/493915964

Game freezes:
End Time: 13:50
Pretender: 19:49 and 20:03

Right after the one at 20:10 I move to my external HDD. Testing at 26:40 and at 28:18 I move back to my internal HDD.

Freezing again at Kanzen Kankaku Dreamer at 33:26

34:20 I talk about what I changed in my PC.

34:35 I kill chrome and repeat the same map that froze a few minutes before. Game runs smoothly.



osu! version: 20131216.26
Lust
Flash player takes up a lot of resources, bundle that with chrome and you are in for a jittery experience.

I always have chatango open on firefox and I lag occasionally.
Coffee Hero
Does this happen when you're not streaming as well?
Topic Starter
Miyazono

TSC wrote:

Does this happen when you're not streaming as well?
Yes


Lust wrote:

Flash player takes up a lot of resources, bundle that with chrome and you are in for a jittery experience.

I always have chatango open on firefox and I lag occasionally.
I have an 3770k OCed to 4.6ghz and 16gb ram dunning 2033mhz. It's not my PC :v)
Topic Starter
Miyazono
Tested last night again.

With chrome + Flash: freezing
With chrome, no flash: smooth
Without chrome + flash: smooth


Guess I can call for now that flash is the only cause for that atm
RBRat3
Try disabling hardware acceleration off in flash. in a flash embed R-click within it > Settings > Display then refresh it.

It should shift H.264 video decoding from the GPU (If supported and being used) to the CPU... play with and see if you get a performance difference out of it.
Topic Starter
Miyazono
Will try that and post results

RBRat3 wrote:

Try disabling hardware acceleration off in flash. in a flash embed R-click within it > Settings > Display then refresh it.

It should shift H.264 video decoding from the GPU (If supported and being used) to the CPU... play with and see if you get a performance difference out of it.
Actually that might be a possibility. I run a 770AMP that has integrated h264 encoder. Not sure if forcing it to CPU would actually solve it, but who knows. Thanks
Topic Starter
Miyazono
Update: still happening after disabling hardware acceleration
RBRat3
Sorry to hear that... I didn't expect it to do much anyways especially with todays hardware but afaik that's the only performance option flash ever provided within itself and worth a play if it was truly the cause.
TicClick
Please sign in to reply.

New reply