forum

osu!Post - Live osu! status for your signatures

posted
Total Posts
166
show more
Topic Starter
givenameplz

fsxd wrote:

Seems i've fixed the lag by updating my graphics driver and net framework, working fine now!~
The usual suspects~
Oinari-sama
I got this message when I lost internet connection tonight. lol it needs to be translated but I can probably guess what it says anyway:

Topic Starter
givenameplz

Oinari-sama wrote:

I got this message when I lost internet connection tonight. lol it needs to be translated but I can probably guess what it says anyway:

This is an annoying one, as its not supposed to happen.
Its a message from the component I am using (experimenting with) right now, this should hopefully be fixed within the next version.

(I usually suppress those pop-ups and output them in the log.)

Edit:
I also updated to a new version, this should fix a few things, I'll rework the update process after this version, changes only take place when you manually restart at the moment.

Edit2:
Will add the ability to adjust the glow color on the website later.
Akhlis
Awesome project! Awesome Idea!
Avail

When I open osu!post
Topic Starter
givenameplz

Avail wrote:


When I open osu!post
(We discussed this on PM, if there is someone else with that problem:)

This is a problem with an old build of osu!Post, this is fixed already, updating and then restarting osu!Post will take care of it.
Oinari-sama
After leaving osu!Post on for a long time (12hrs+) yesterday, it was somewhat un-responsive when I tried to turn it off. I finally managed to turn it off by unchecking "Enable post" and "Show preview output" but my sig has been displaying "Online" since last night.

The log mentioned a certain error that "you would love to hear" so I'm posting it lol

The texts are a bit hard to read because the screenshot was taken when the program was busy.

Memory usage just before I killed it:
Topic Starter
givenameplz

Oinari-sama wrote:

After leaving osu!Post on for a long time (12hrs+) yesterday, it was somewhat un-responsive when I tried to turn it off. I finally managed to turn it off by unchecking "Enable post" and "Show preview output" but my sig has been displaying "Online" since last night.

The log mentioned a certain error that "you would love to hear" so I'm posting it lol

The texts are a bit hard to read because the screenshot was taken when the program was busy.

Memory usage just before I killed it:
Alright, thanks for posting. I think I know whats causing this, I will start some more long term tests later.

Edit: Should be fixed with the upcoming version. I will also add options for text alignment later at some point. (eg. left align, right align or centered between two points, like the name is now.)
Topic Starter
givenameplz
I sneaked in a few options for the custom signatures a while ago and also improved a few things in the background.
Everything should be explained if you hover over the tags under "About the positioning values:"

Some new things are:
  1. Adjust glow colors.
  2. Adjust status output slightly. (Hide your name and only show "[Online]" or "[Offline]".)
  3. Adjust map data ouput slightly. (Actually not really worth mentioning, but you can hide the "Playing:" label.)
  4. "Save & Preview" button. (You can also see your uploaded picture correctly now.)


The tags for the output adjustments are named full_output right now and can be set to either 1 (on, full output) or 0 (off, slightly altered output).
(I might rename those tags in the future, but this won't cause any problems, so don't worry.)

Access them here by pressing on the "Configure" button in the "Custom signature:" section.
Daniel58[MC]
Tried two minutes ago dont work for me.

[Exception]
Uncaught exception! (EAccessViolation)
Please tell givenameplz, he would love to hear this!
Topic Starter
givenameplz

Daniel58[MC] wrote:

Tried two minutes ago dont work for me.

[Exception]
Uncaught exception! (EAccessViolation)
Please tell givenameplz, he would love to hear this!
I am already aware of that problem.
This problem will be fixed within the next update, thanks for the report.
(Release within the next days.)
Daniel58[MC]
Ok thanks I will be waiting for it.
Topic Starter
givenameplz
Released a new version containing mostly fixes and performance updates.
As said, this should fix the "exception problem", if its still consistent please drop me a post or a PM.
(I also changed the auto updating to be more efficient.)

Get it here or simply run your osu!Post and restart it after the update.
Oinari-sama
You might wanna add a version/build number somewhere now
Daniel58[MC]
Working now.
Thanks :)
R-A-I-N
eto... how to change the background?
Topic Starter
givenameplz

R-A-I-N wrote:

eto... how to change the background?
First go here.
There you can select a template one or create your own from scratch and upload it with the button below thats saying Configure in the section Custom signature:.
By editing the number values in the input field you can change the output positioning, for more information about the values, hover over the tags above the input field there.

Edit: @Oinari-sama you can already see it in the very first [Info] output, but I will put it somewhere else as well.
R-A-I-N

givenameplz wrote:

R-A-I-N wrote:

eto... how to change the background?
First go here.
There you can select a template one or create your own from scratch and upload it with the button below thats saying Configure in the section Custom signature:.
By editing the number values in the input field you can change the output positioning, for more information about the values, hover over the tags above the input field there.

Edit: @Oinari-sama you can already see it in the very first [Info] output, but I will put it somewhere else as well.
ow thank you
ps: why you not add ability to start automatical when startup or when i open osu! lel
Stefan
[Preview]
Failed to show preview image! (EIdSocketError)

Also my banner doesn't update but I guess these issues are connected. What to do?
Oinari-sama
There is currently a problem for those playing osu full screen. The banner shows your Online/Offline status, but does not show song info. This is related to a fix in the latest osu update:
[peppy] Don't set window title when running osu! fullscreen.
I believe that givenameplz is working on a solution at the moment. For time being, those affected can try using borderless instead (which still displays song info through your signature).
show more
Please sign in to reply.

New reply