[Archived] Spinner lag

posted
Total Posts
14
Topic Starter
Cervby
Problem Details:
It lags sometimes for me when I'm spinning. It has been like that for a very long time(several months), but I've been too lazy to do anything about it.
In the video you can see if you look at the right, where it shows the clicks, that osu! seems to think that i'm clicking while I'm spinning, even though I'm actually holding the button down the whole time while I'm spinning.

Video or screenshot showing the problem:



osu! version: 20131024.1 (latest)
Rorona
Is OS TabletPC support enabled?
Topic Starter
Cervby

Rorona wrote:

Is OS TabletPC support enabled?
Seems like I have it enabled.
I'm not using a tablet though.
FrzR
Disable it then :D

Also, if you're lagging on spinners, you can use the old skin behavior on the skins tab, or use a different skin. The new default spinner lags me a bit as well.
MillhioreF
There's a known bug where spinners will lag just a tiny bit the first time one appears after running osu!, but if it keeps lagging all the time then it's likely a different issue. The old spinner has less parts and less complicated effects, so switching to it is probably a good idea.
peppy

MillhioreF wrote:

There's a known bug where spinners will lag just a tiny bit the first time one appears after running osu!, but if it keeps lagging all the time then it's likely a different issue. The old spinner has less parts and less complicated effects, so switching to it is probably a good idea.
This issue was resolved a while back, so should nto be occurring anymore.
Topic Starter
Cervby

Fr33z3R wrote:

Disable it then :D

Also, if you're lagging on spinners, you can use the old skin behavior on the skins tab, or use a different skin. The new default spinner lags me a bit as well.
Changing the skin doesn't seem to help and disabling OS TabletPC doesn't seem to make any difference either.

MillhioreF wrote:

There's a known bug where spinners will lag just a tiny bit the first time one appears after running osu!, but if it keeps lagging all the time then it's likely a different issue. The old spinner has less parts and less complicated effects, so switching to it is probably a good idea.
It's not just the first time a spinner appears. It's completely at random, sometimes the spinner lags lags and sometimes it does not.
Topic Starter
Cervby
I'd really want a solution to this. It's extremely irritating and annoying to fail on the spinner just because it doesn't work properly.
TheVileOne
Well I would suggest turning the video off if you're having lag problems for one. I think having the hit error tracker can cause delays too.
FrzR

TheVileOne wrote:

I think having the hit error tracker can cause delays too.
I have the tracker on but i didn't really experience much delays. Though i get distracted by seeing if i got the timing right or wrong. xD
Full Tablet

Fr33z3R wrote:

TheVileOne wrote:

I think having the hit error tracker can cause delays too.
I have the tracker on but i didn't really experience much delays. Though i get distracted by seeing if i got the timing right or wrong. xD
The tracker seems to increase RAM usage a little while playing maps, which might cause lag if the PC has a low amount of RAM.
Topic Starter
Cervby

TheVileOne wrote:

I think having the hit error tracker can cause delays too.

Full Tablet wrote:

Fr33z3R wrote:

I have the tracker on but i didn't really experience much delays. Though i get distracted by seeing if i got the timing right or wrong. xD
The tracker seems to increase RAM usage a little while playing maps, which might cause lag if the PC has a low amount of RAM.
Turning off the hit error tracker doesn't seem to help. I have a lot of free ram so that shouldn't be the problem, and high cpu usage shouldn't be the problem either.
TheVileOne
I can't tell if it's osu's fault or your input drivers bugging out. I'm looking at your spinning and it doesn't look like display lag. Your cursor goes screwy and this causes your spm to drop. I would call this as a form of dropping inputs or an inaccurate tracking of the cursor. My mouse does this to me all the time since it is wireless and my computer is bad. It usually works perfectly if it's at full charge and I've given my computer some time to warm up before I start playing.

I've never checked whether it counted extra inputs when it happens. That could just be the program detecting a dropped input and considering it a new button press when it finds the connection again.

My suggestions

I find it curious that your game locks the FPS at 60 during the spinners. 60 FPS is not very good for spinning. I recommend setting Frame Limiter to unlimited or something higher than 60. It should not be defaulting to 60 if you have the framelimiter set to anything else. It might be a video card or monitor refresh rate problem if the FPS during spinners doesn't go above 60.

Your spinning should be smoother than that if you have a wired mouse. Sometimes I've experienced that kind of behavior with my wireless mouse. Your computer might be having problems dealing with the spinner and the video playing at the same time. Aging hardware may not be running at optimal efficiency.

Test a different mouse on your computer. A new mouse with fresh drivers will probably fix your problems.
Topic Starter
Cervby

TheVileOne wrote:

I can't tell if it's osu's fault or your input drivers bugging out. I'm looking at your spinning and it doesn't look like display lag. Your cursor goes screwy and this causes your spm to drop. I would call this as a form of dropping inputs or an inaccurate tracking of the cursor. My mouse does this to me all the time since it is wireless and my computer is bad. It usually works perfectly if it's at full charge and I've given my computer some time to warm up before I start playing.

I've never checked whether it counted extra inputs when it happens. That could just be the program detecting a dropped input and considering it a new button press when it finds the connection again.

My suggestions

I find it curious that your game locks the FPS at 60 during the spinners. 60 FPS is not very good for spinning. I recommend setting Frame Limiter to unlimited or something higher than 60. It should not be defaulting to 60 if you have the framelimiter set to anything else. It might be a video card or monitor refresh rate problem if the FPS during spinners doesn't go above 60.

Your spinning should be smoother than that if you have a wired mouse. Sometimes I've experienced that kind of behavior with my wireless mouse. Your computer might be having problems dealing with the spinner and the video playing at the same time. Aging hardware may not be running at optimal efficiency.

Test a different mouse on your computer. A new mouse with fresh drivers will probably fix your problems.
I have fps set to unlimited, if you look at the video you can see that I had around 120 fps before the spinner.

I'm getting a new graphic card on Christmas (GeForce 9500 GT to Radeon HD 7790 ), I hope that will make the lagging stop.

Sometimes there are a lot of spinner lag and sometimes there's none, I don't seem to be getting any lag right now so I can't test if switching mouse would work. I'll come back later when the lag comes back to tell whether switching the mouse helped.
Please sign in to reply.

New reply