1. osu! forums
  2. osu!
  3. Gameplay & Rankings
show more
posted
make sure that mouse acceleration is off
posted

Soulg wrote:

make sure that mouse acceleration is off
I made sure that was off. That's one thing I always make sure is turned off...and I think I already fixed it. I switched to OpenGL mode and now I don't seem to be having the issue as badly...seems weird to me...but eh.
posted
Turn off vsync (Press f7 a couple of times)
posted
try DirectX with 120fps limit.

Also, are you playing in window mode? It tends to lag sometimes. Try fullscreen
posted
Usually a good idea to disable visual themes and desktop composition in the osu! shortcut properties if you're in Windows 7. Not sure about Windows 8.

GFX driver settings should also have pre-rendered frames 0 (Nvidia) or flip-queue size 0 (AMD - via ATI tray tools or RadeonPro).

Those are the only 2 things that cause cursor lag for me.

Fullscreen performs better because windows disables its visual themes and desktop composition automatically when a fullscreen application is running. However you can do that manually and run fine in windowed mode.

Another possible issue is that you could have a low-end HTPC graphics card (200fps? srs?), which are generally limited in how many transparency layers they can render at a great performance cost. Spinners do a lot of this and can cause the lag you are experiencing. If not, it may not hurt to try fiddling with the transparency settings in your drivers anyway.
posted
The only way to disable desktop composition on Windows 8 (without breaking the Start screen) is to switch to full-screen and back. But even then, you'll still have 1-2 frames of visual delay. I'd recommend playing in full screen if possible.

But it sounds like you're getting framerate drops. 200fps is actually a fairly low framerate for this game in Unlimited.
Are you playing on a laptop? If so, are you using the "High Performance" power option? Do you have background videos turned off? Have you tried playing with Snaking Sliders turned off?
posted

[AirCoN] wrote:

Turn off vsync (Press f7 a couple of times)
I mentioned above that I already have that turned off...

AmaiHachimitsu wrote:

try DirectX with 120fps limit.

Also, are you playing in window mode? It tends to lag sometimes. Try fullscreen
I was playing fullscreen mode before, and I switched to windowed mode. There wasn't any difference in performance. And I have to play in a window now, my current monitor...uhm, makes it hard to play in fullscreen.. (It's 40 inches..) and I don't think putting a limit on my framerate would really help...(and I've already tried that, but thanks anyways.)

RaneFire wrote:

Usually a good idea to disable visual themes and desktop composition in the osu! shortcut properties if you're in Windows 7. Not sure about Windows 8.

GFX driver settings should also have pre-rendered frames 0 (Nvidia) or flip-queue size 0 (AMD - via ATI tray tools or RadeonPro).

Those are the only 2 things that cause cursor lag for me.

Fullscreen performs better because windows disables its visual themes and desktop composition automatically when a fullscreen application is running. However you can do that manually and run fine in windowed mode.

Another possible issue is that you could have a low-end HTPC graphics card (200fps? srs?), which are generally limited in how many transparency layers they can render at a great performance cost. Spinners do a lot of this and can cause the lag you are experiencing. If not, it may not hurt to try fiddling with the transparency settings in your drivers anyway.
Well I can tell you I don't have a low-end HTPC graphics card. It's a EVGA GTX660 SuperClocked edition, It cost me something like $230 so I know it's not very low end. I haven't actually tried to tweak any graphic card settings really, maybe I should try doing that. And...come on ...if window's visual themes are making the game lag...how is that even possible? I mean, I know how it's possible but I've got enough resources to run like 5 resource heavy games at the same time and none of them would be lagging really. But then again...I've noticed stupid lag issues with just about every 2D game I try to play, and especially when im trying to Stream it.

Thanks for all the replies but the majority of you have completely missed my post where I said I switched to OpenGL mode and the lag has seemed to stop...like the lowest my framerate goes now is like 1,500fps. Or maybe you didn't miss it, but it is there..
posted

redbl0odx wrote:

But then again...I've noticed stupid lag issues with just about every 2D game I try to play, and especially when im trying to Stream it.

Thanks for all the replies but the majority of you have completely missed my post where I said I switched to OpenGL mode and the lag has seemed to stop...like the lowest my framerate goes now is like 1,500fps. Or maybe you didn't miss it, but it is there..
We didn't miss that at all. I know, as well as many others, that OpenGL performs better than DirectX in terms of input and video render delay. OpenGL is kept around as an alternative renderer for your particular problem as a temporary solution, until you can find out what's going on. The problem is compatibility in this mode with osu! itself, as it is usually prone to crashes and graphical errors upon osu! updates, until fixed. DirectX is primarily supported and has very little issues.

Visual themes and desktop composition cause video "delay" - not erratic lag, as you are experiencing. I thought they would be worth mentioning as you gave no specifics on your PC, and still haven't mentioned your version of windows. And even Yaymii assumed you're playing on a laptop, it's so bad. I also have a 5 year old Toshiba Satellite laptop around, with integrated graphics and get 300fps+ at all times. So you cannot blame us for coming to such assumptions.

My desktop has a low-end "gaming card" and disabling these options in windows does make a difference (Radeon 6770).
Also to note: I get 1500-2200fps in DirectX mode, but only ~500fps in OpenGL, unlimited. I remember getting even higher frame rates in OpenGL earlier this year/last year, so I am a bit confused over this as well.

If you do a quick google search on your card, you'll see that there are plenty of other people experiencing lots of different problems with it, mostly software/driver related. It's not just you. I do wish you the best in finding a solution though.
posted

RaneFire wrote:

redbl0odx wrote:

But then again...I've noticed stupid lag issues with just about every 2D game I try to play, and especially when im trying to Stream it.

Thanks for all the replies but the majority of you have completely missed my post where I said I switched to OpenGL mode and the lag has seemed to stop...like the lowest my framerate goes now is like 1,500fps. Or maybe you didn't miss it, but it is there..
We didn't miss that at all. I know, as well as many others, that OpenGL performs better than DirectX in terms of input and video render delay. OpenGL is kept around as an alternative renderer for your particular problem as a temporary solution, until you can find out what's going on. The problem is compatibility in this mode with osu! itself, as it is usually prone to crashes and graphical errors upon osu! updates, until fixed. DirectX is primarily supported and has very little issues.

Visual themes and desktop composition cause video "delay" - not erratic lag, as you are experiencing. I thought they would be worth mentioning as you gave no specifics on your PC, and still haven't mentioned your version of windows. And even Yaymii assumed you're playing on a laptop, it's so bad. I also have a 5 year old Toshiba Satellite laptop around, with integrated graphics and get 300fps+ at all times. So you cannot blame us for coming to such assumptions.

My desktop has a low-end "gaming card" and disabling these options in windows does make a difference (Radeon 6770).
Also to note: I get 1500-2200fps in DirectX mode, but only ~500fps in OpenGL, unlimited. I remember getting even higher frame rates in OpenGL earlier this year/last year, so I am a bit confused over this as well.

If you do a quick google search on your card, you'll see that there are plenty of other people experiencing lots of different problems with it, mostly software/driver related. It's not just you. I do wish you the best in finding a solution though.
To be honest this started rather recently. I've had this card for quite a while now, and I haven't really run into any issues until recently.

And I suppose to give more specifics on my computer. Windows 7 Ultimate 64-bit. 8gb DDR3 memory.. GTX660 2GB GDDR5 memory.
It might be a case where my computer is just slowing down and needs a good cleaning...a few of my other games that normally ran perfectly are starting to run into issues.

Thanks to you all for the quick replies. I will likely reformat my system after backing up some files/games/osu! and I'll let you guys know if it's fixed, if not I'll start playing around with the settings you guys mentioned.. Though for now at least OpenGL is making it playable.
posted
Did you turn off vsync in video card settings. Also, whats your monitor refresh rate. If you change mouse and the problem still persists, i suspect its a monitor/graphics card issue
posted
This may be a result of Windows 8.1.

Check the Tech Support thread for more details, I don't know too much.
posted
Games often install things, as do software. They require certain updates to DirectX or other drivers to run properly. Just because it started recently does not mean it isn't software related.

One user mentioned that his problem also started recently, right after installing GeForce Experience. He re-installed his windows though, it fixed his problem (extreme solution). Manufacturers also recommend uninstalling your drivers before installing the latest version. Although it isn't always necessary, it prevents a few problems. You could try this first.

Anyway you are not likely to get any expert help on this matter, as this is a gaming forum. I know very little myself as I only once "had" nvidia cards, but gave up on nvidia for a few reasons.
posted

RaneFire wrote:

Games often install things, as do software. They require certain updates to DirectX or other drivers to run properly. Just because it started recently does not mean it isn't software related.

One user mentioned that his problem also started recently, right after installing GeForce Experience. He re-installed his windows though, it fixed his problem (extreme solution). Manufacturers also recommend uninstalling your drivers before installing the latest version. Although it isn't always necessary, it prevents a few problems. You could try this first.

Anyway you are not likely to get any expert help on this matter, as this is a gaming forum. I know very little myself as I only once "had" nvidia cards, but gave up on nvidia for a few reasons.
Well I do appreciate the help. Truly I do. And I don't doubt it's some software issue. But considering how much multi-tasking I do on this machine, it's really hard to pinpoint what exactly I did that made the whole system slow down. I do everything from casual Word/Excel use, to hacking, video editing, animations, cracking..pirating...hacking things, making small tweaks to stuff to customize my computer. Get where I am going? Heh, the quickest and easiest solution would be to format. (Honestly its not that extreme to me anymore...I've been building and fixing computers since I was a little kid so...I'll have my computer back to normal in no time if I do format.) Did I mention that I only started having this problem, I think shortly after I moved to a new monitor? (It's a 40inch screen at 1080p and 60hz refresh.) ALSO I normally opt out of the whole nvidia experience thing, I have no use for it.

I'll likely just format. This is normal for my computer sometimes. I always format like every 6 or 7 months, just to keep things fresh. Not because my computer messes up, but just to get that "fresh" feel every so often and have all my lost speed back.

Rorona wrote:

This may be a result of Windows 8.1.

Check the Tech Support thread for more details, I don't know too much.
Considering I am on windows 7....I don't think that's the issue.

[AirCoN] wrote:

Did you turn off vsync in video card settings. Also, whats your monitor refresh rate. If you change mouse and the problem still persists, i suspect its a monitor/graphics card issue
I generally have vsync turned off on everything that allows me to. My monitor refresh rate is 60hz. It's 1920x1080 and its a 40inch screen.
posted
Perhaps check your resource usage (CPU/RAM usage in Task Manager, GPU usage in a program like MSI Afterburner), and see if the numbers are unusually high. If you notice something, you should be able to look through the list of processes and easily spot the culprit.
posted

YayMii wrote:

Perhaps check your resource usage (CPU/RAM usage in Task Manager, GPU usage in a program like MSI Afterburner), and see if the numbers are unusually high. If you notice something, you should be able to look through the list of processes and easily spot the culprit.
I did what you suggested and I didn't see anything unusual. I'll figure this out sooner or later, or format.
posted
What mouse do you have? Laser mice have around 5% built in acceleration that you cannot remove.
posted

Gimmesoup wrote:

What mouse do you have? Laser mice have around 5% built in acceleration that you cannot remove.
It's not from that unless it somehow magically turned on and I wasn't aware of it. It's just a really generic optical mouse. I know the issue, it's lag. Not my mouse.
Please sign in to reply.