1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
show more
posted
@Hz133: update your drivers to the latest available at nvidia.com and try again.
posted
This map has been deleted on the request of its creator. It is no longer available.
posted
posted
I've reinstalled everything, and it's still not working (except OpenGL ofc, but it's too laggy...).
posted
I understand there is some kind of problem here bug have no way to replicate it. Are you guys able to provide any other details you can? Have you tried (DirectX) using the Autoplay mode? the editor? different maps? turning off snaking?
posted
For me, at least:

When snaking is on, the final circle moves along the path the slider would have taken, but no slider body actually shows up. When snaking is off, then the two endcircles appear without a body. Neither way works.

Autoplay does nothing, the slider body still isn't visible.

No map I've tried works.

The editor has the same problem, as does the editor test mode. I get an error message intermittently, I don't know if it's only in editor test, but that's the only place I've gotten it so far (twice, I think)... i'll try to get that error again and post it here, but it might have been sent to you earlier(?). I remember that it was something about needing both a pixel and vertex shader, and there was something that looked like a function declaration.

EDIT: Ah, I got it when starting test in the middle of a slider. It showed a white sliderbody, and then crashed to this error (spoiler'd):
System.InvalidOperationException: Both a valid vertex shader and pixel shader (or valid effect) must be set on the device before draw operations may be performed.

at Microsoft.Xna.Framework.Graphics.GraphicsDevice.VerifyCanDraw(Boolean bUserPrimitives, Boolean bIndexedPrimitives)

at Microsoft.Xna.Framework.Graphics.GraphicsDevice.DrawIndexedPrimitives(PrimitiveType primitiveType, Int32 baseVertex, Int32 minVertexIndex, Int32 numVertices, Int32 startIndex, Int32 primitiveCount)

at #6U.#4d.Draw(List`1 , Single , Color , Single , String , Boolean )

at #YX.#UX.Draw()

at #4X.#lf.#5F()

at #ee.#Re.Draw(GameTime )

at Microsoft.Xna.Framework.Game.DrawFrame()


EDIT2: after that error and a click on "Restart osu!", I needed to force-kill osu!, if that's relevant at all
posted
Okay, I will describe it in the simple way:

With no Snaking Sliders with DirectX:
Osu normal mode: Sliders are invisible
Osu normal mode with AutoPlay: Sliders are visible
Osu Edit mode: Sliders are invisible
Osu Edit test mode: Sliders are invisible
Osu Edit test mode with Autoplay: Sliders are visible.

With Snakin Sliders with DirectX:
There's no difference.
posted
DirectX with frame limiter off, as well as all GFX options except background video, using the default skin


Normal mode with auto



Normal mode playing un-modded
posted
This will be fixed in the new public release (available in ~5minutes).
posted
I still can't see my slider bars, I just started playing Osu and instead of sliders I see a bunch of pictures, is it my computer? I play on that openGI, I can't play on DirectX, what should I do?
posted

najo4 wrote:

I still can't see my slider bars, I just started playing Osu and instead of sliders I see a bunch of pictures, is it my computer? I play on that openGI, I can't play on DirectX, what should I do?
You should provide as much info as possible
posted
please delete this post :oops:
posted

peppy wrote:

I understand there is some kind of problem here bug have no way to replicate it. Are you guys able to provide any other details you can? Have you tried (DirectX) using the Autoplay mode? the editor? different maps? turning off snaking?
All works in window mode. But i can't play in fullscreen mode using DirectX. Maybe it's only on my PC only.
Now about sliders. At resolution 1024x768 after minimize/restore window i can see this picture
. But at 800x600 i see normal sliders with same settings, even after minimize/restore window.
posted
Hz133, looks like you don't have enough video RAM. Do you know how much video RAM you have?
posted
strager, i have 256 MB of video RAM. (ZOTAC Ge-Force 8600GT 128-bit PCI-E).
Please sign in to reply.