1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
show more
posted
Yes... my "card" don't suport the directX mode...
So I can't resolve this bug? D:
posted

ppmagno_x wrote:

So I can't resolve this bug? D:
You, maybe not. One of the developers, maybe.

Reply to my post please.

Also, try updating your video drivers.
posted
Update your graphics card drivers.
posted
Okay, I hope this isn't a bump, but I'm having the same problem. My graphics card drivers are up-to-date. When I switch to OpenGl mode, I can see the slider bars, but it's impossible for me to play the game on that mode because it runs too slowly. When I switch back to DirectX, the slider bars are invisible again. I've tried messing around with the graphics settings and even reinstalling, but it didn't work.

The strange thing is... everything worked fine until I updated osu today (and I've been playing for over a year, mind you). I only started having this problem then. What should I do?
posted
^

Also, I spin about 330-340 per minute, but before update it was 450-460.
posted
This map has been deleted on the request of its creator. It is no longer available.
posted

FourEyes wrote:

Okay, I hope this isn't a bump, but I'm having the same problem. My graphics card drivers are up-to-date. When I switch to OpenGl mode, I can see the slider bars, but it's impossible for me to play the game on that mode because it runs too slowly. When I switch back to DirectX, the slider bars are invisible again. I've tried messing around with the graphics settings and even reinstalling, but it didn't work.

The strange thing is... everything worked fine until I updated osu today (and I've been playing for over a year, mind you). I only started having this problem then. What should I do?
After I updated to b824, my DirectX sliders stopped showing, also. Switching to OpenGL worked reasonably well, except for glitches on some maps, like Ooparts.

I have a Mobility Radeon 9000, DirectX 9.0c, and an ancientish Dell laptop. The latest driver is from December 2005... and I tried updating to that one, and the sliders are still missing.

'm not sure what's going on, might be something with my computer cause lots of other people don't really have problems
posted
So... there is no way to fix this for those who can't play in Open GL? Oh God, I'm gonna go crazy. I can't play like this. D:
posted

fartownik wrote:

Also, I spin about 330-340 per minute, but before update it was 450-460.
You must not have played in a few months. IIRC spinner RPM calculation changed a while ago. It's rare to get above 420 for us humans.
posted
Strangely enough, after reinstalling my drivers, I can play in OpenGL mode with minimal problems. I still have no idea why DirectX suddenly started being so troublesome, but at least, half of the problem is fixed!
posted

chaosanime wrote:

I think it's a bug in the latest beta release, I have the same problem

I do use directx mode btw
For a bit more info, it worked perfectly before I updated to somewhere around b824, same settings

It runs in opengl, but not with frame limiter off, and thus un-playable. Note this is an old(&temporary) computer (nvidia4200, P4)

Still not fixed in b829a
posted
I can't see slider bars too, but only after minimize/restore.
I have also problem with dx mode in fullscreen, it doesn't work ("Your graphic card does not seem support shader model 1.1+"). My videocard is GeForce 8600GT with sm 4. Is it support sm 1.1+ ?
posted
@Hz133: update your drivers to the latest available at nvidia.com and try again.
posted
This map has been deleted on the request of its creator. It is no longer available.
posted
posted
I've reinstalled everything, and it's still not working (except OpenGL ofc, but it's too laggy...).
posted
I understand there is some kind of problem here bug have no way to replicate it. Are you guys able to provide any other details you can? Have you tried (DirectX) using the Autoplay mode? the editor? different maps? turning off snaking?
posted
For me, at least:

When snaking is on, the final circle moves along the path the slider would have taken, but no slider body actually shows up. When snaking is off, then the two endcircles appear without a body. Neither way works.

Autoplay does nothing, the slider body still isn't visible.

No map I've tried works.

The editor has the same problem, as does the editor test mode. I get an error message intermittently, I don't know if it's only in editor test, but that's the only place I've gotten it so far (twice, I think)... i'll try to get that error again and post it here, but it might have been sent to you earlier(?). I remember that it was something about needing both a pixel and vertex shader, and there was something that looked like a function declaration.

EDIT: Ah, I got it when starting test in the middle of a slider. It showed a white sliderbody, and then crashed to this error (spoiler'd):
System.InvalidOperationException: Both a valid vertex shader and pixel shader (or valid effect) must be set on the device before draw operations may be performed.

at Microsoft.Xna.Framework.Graphics.GraphicsDevice.VerifyCanDraw(Boolean bUserPrimitives, Boolean bIndexedPrimitives)

at Microsoft.Xna.Framework.Graphics.GraphicsDevice.DrawIndexedPrimitives(PrimitiveType primitiveType, Int32 baseVertex, Int32 minVertexIndex, Int32 numVertices, Int32 startIndex, Int32 primitiveCount)

at #6U.#4d.Draw(List`1 , Single , Color , Single , String , Boolean )

at #YX.#UX.Draw()

at #4X.#lf.#5F()

at #ee.#Re.Draw(GameTime )

at Microsoft.Xna.Framework.Game.DrawFrame()


EDIT2: after that error and a click on "Restart osu!", I needed to force-kill osu!, if that's relevant at all
posted
Okay, I will describe it in the simple way:

With no Snaking Sliders with DirectX:
Osu normal mode: Sliders are invisible
Osu normal mode with AutoPlay: Sliders are visible
Osu Edit mode: Sliders are invisible
Osu Edit test mode: Sliders are invisible
Osu Edit test mode with Autoplay: Sliders are visible.

With Snakin Sliders with DirectX:
There's no difference.
posted
DirectX with frame limiter off, as well as all GFX options except background video, using the default skin


Normal mode with auto



Normal mode playing un-modded
show more
Please sign in to reply.