1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
The problem is the same of this topic
http://osu.ppy.sh/forum/viewtopic.php?f=29&t=12011&hilit=slide
I can't change to DirectX mode... so, the topic posted don't help me :|
posted
Why can't you change to DirectX Mode? :/
posted

Derekku Chan wrote:

Why can't you change to DirectX Mode? :/
Probably because his video card does not support shaders, just as mine, and DirectX mode doesn't work.
posted
Post system specs. In particular, your video card and its RAM capacity.
posted
Yes... my "card" don't suport the directX mode...
So I can't resolve this bug? D:
posted

ppmagno_x wrote:

So I can't resolve this bug? D:
You, maybe not. One of the developers, maybe.

Reply to my post please.

Also, try updating your video drivers.
posted
Update your graphics card drivers.
posted
Okay, I hope this isn't a bump, but I'm having the same problem. My graphics card drivers are up-to-date. When I switch to OpenGl mode, I can see the slider bars, but it's impossible for me to play the game on that mode because it runs too slowly. When I switch back to DirectX, the slider bars are invisible again. I've tried messing around with the graphics settings and even reinstalling, but it didn't work.

The strange thing is... everything worked fine until I updated osu today (and I've been playing for over a year, mind you). I only started having this problem then. What should I do?
posted
^

Also, I spin about 330-340 per minute, but before update it was 450-460.
posted
This map has been deleted on the request of its creator. It is no longer available.
posted

FourEyes wrote:

Okay, I hope this isn't a bump, but I'm having the same problem. My graphics card drivers are up-to-date. When I switch to OpenGl mode, I can see the slider bars, but it's impossible for me to play the game on that mode because it runs too slowly. When I switch back to DirectX, the slider bars are invisible again. I've tried messing around with the graphics settings and even reinstalling, but it didn't work.

The strange thing is... everything worked fine until I updated osu today (and I've been playing for over a year, mind you). I only started having this problem then. What should I do?
After I updated to b824, my DirectX sliders stopped showing, also. Switching to OpenGL worked reasonably well, except for glitches on some maps, like Ooparts.

I have a Mobility Radeon 9000, DirectX 9.0c, and an ancientish Dell laptop. The latest driver is from December 2005... and I tried updating to that one, and the sliders are still missing.

'm not sure what's going on, might be something with my computer cause lots of other people don't really have problems
posted
So... there is no way to fix this for those who can't play in Open GL? Oh God, I'm gonna go crazy. I can't play like this. D:
posted

fartownik wrote:

Also, I spin about 330-340 per minute, but before update it was 450-460.
You must not have played in a few months. IIRC spinner RPM calculation changed a while ago. It's rare to get above 420 for us humans.
posted
Strangely enough, after reinstalling my drivers, I can play in OpenGL mode with minimal problems. I still have no idea why DirectX suddenly started being so troublesome, but at least, half of the problem is fixed!
posted

chaosanime wrote:

I think it's a bug in the latest beta release, I have the same problem

I do use directx mode btw
For a bit more info, it worked perfectly before I updated to somewhere around b824, same settings

It runs in opengl, but not with frame limiter off, and thus un-playable. Note this is an old(&temporary) computer (nvidia4200, P4)

Still not fixed in b829a
posted
I can't see slider bars too, but only after minimize/restore.
I have also problem with dx mode in fullscreen, it doesn't work ("Your graphic card does not seem support shader model 1.1+"). My videocard is GeForce 8600GT with sm 4. Is it support sm 1.1+ ?
posted
@Hz133: update your drivers to the latest available at nvidia.com and try again.
posted
This map has been deleted on the request of its creator. It is no longer available.
posted
posted
I've reinstalled everything, and it's still not working (except OpenGL ofc, but it's too laggy...).
show more
Please sign in to reply.