1. osu! forums
  2. osu!
  3. Gameplay & Rankings
posted
Can people please post all of the methods they use to disable software lag?
It pains my eyes to see the lag between my mouse and my cursor every time I move it and I want to get rid of it completely. Disabling Aero alone did not completely rid of it. Are there any other methods?
posted
Close every process in task manager, as long as it is not svchost, or some critical system features, and then check one by one which one casues lag ;~; best idea IMO.

Also there is not such thing

I misunderstood didn't I?
posted
there is this topic but i dont know if that does what you're looking for p/2072245
posted

silmarilen wrote:

there is this topic but i dont know if that does what you're looking for p/2072245
This is relevant to my interests, thank you.
posted
Full screen is your best bet as playing windowed will force your game to relay through windows itself rather than utilizing the graphic buffers solely. Don't limit your FPS lower than 450~ FPS and of course don't us any extra buffers. The smaller the screen resolution the more it will rely on your processor than the graphics card. Using a 120hz+ monitor also helps reduce latency. Use game booster to but don't run osu! Through it; instead just set it to game mode and disable most all processes and services you know you won't need.
posted
also depends on the polling rate of the mice you're using. on some gaming mices you can change it in the software
posted

silmarilen wrote:

there is this topic but i dont know if that does what you're looking for https://osu.ppy.sh/forum/p/2072245
Issue fixed
**I would advice you to not follow that guide. For some reason osu! is unplayable... all sliders have started to generate lag.

I tried to return the settings to what they were before, but the problem is still there. >_>**
posted
Reset your universal offset to 0 zakdawg.
posted

Dexus wrote:

Reset your universal offset to 0 zakdawg.
issue fixed
**universal audio offset?

So far I can conclude that shaking sliders has become the villain. Why I dont know.**
posted
If it wasn't the offset that was the next option I was going to suggest. As for sliders being weird? I don't know. Hopefully they get tuned up or something.
posted
issue fixed
**I think you might have misunderstood me. I have no issue with offset... my offset has always been 0.

The problem is sliders with shaking sliders enabled (which i have used for over a year) started to generate lag. So much that osu! freezes if there are 3-4 sliders at the same time. This all happened after I tried to follow the steps in your guide to see if it was actually noticeable improvements.

Also osu! showed 450+ fps before, and now it is sitting around 300... so something has gone wrong, and i'm trying to see if it can be fixed or if something got fucked up with my gpu.**
posted
No I understood what you said. Did you modify the mouse polling or anything? Are your graphics card drivers up to date? (you shouldn't downgrade your drivers ever ) Honestly the guide I did doesn't affect it that much (it's more fine tuning than anything). You must have messed up something on your own. If you're on nvidia set 1 max pre-rendered frame (the 0 option was removed). For AMD set 0 flip queue in RadeonPro ( it's truthfully 1)
posted
Hey

Okay i seem to have located the issue and "fixed" it

First to say I did not mess something up on my own, but for whatever reason my computer was always using the integrated graphics instead of choosing my nividia card.

But just to completely state my issue. It was nothing with offset, accuracy, mouse polling or anything of that sort. A slider would appear and i would lose around 100 fps... 4 sliders at the same time (Right after each others) and my fps would drop to around 0.


Now regarding the guide. I did manage to make a nice new high score that I would consider one of my best plays, before all hell happened. :)
posted
Outside of 500hz USB polling rate, unlimited FPS, disabling v-sync, disabling Aero and lowering pre-rendered frames to 0...
you can overclock your CPU/GPU and lower your graphics settings.

Hardware-wise, your best bang for the buck would be a monitor a low input lag (important: different from response time and never mentioned by the manufacturer).
If you want to shell out the cash for a 120hz+ monitor with low input lag, then you'll shave an average of 8.3ms+ off your total input lag.

The only way to find out the monitor's input lag is to have a professional test it and post their review on a site such as this:
http://www.prad.de/en/monitore/reviews.html
posted
It's may because of your graphic card selection problem.
When OSU is running, the default graphic card is used, not high performance one. That's why OSU is lagged.
So you click right button on OSU icon, and click "run with graphics processor" and select higher graphic card.
posted
Holy necro
posted
don't necropost please
Please sign in to reply.