1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
Game is sluggish as hell and i'm having serious response issues, and also sometimes clicks arent registering.

I have a one month of Razer Deathadder 2013, any chance its the game?

osu! version: 20130926 (latest)
posted
Maybe you accidentally changed the frame limiter? It happened once to me before. Frame limiter is F7.
posted
There are 3 things that can cause this issue
Hardware,Frame Rate or Your System
posted
I wonder if you are using usb or ps/2 connector. If you have a chance, please use the latter one.
posted
What is the default frame limiter?
posted
I think it was 120 but you should choose one of them where you'll have a smooth gameplay.
posted

Nathanael wrote:

I think it was 120 but you should choose one of them where you'll have a smooth gameplay.
Tried another mouse i had (deathadder 1800) still doing it.

Is it possible that the new update changed something and it is conflicting with my drivers?
posted

SolviteSekai wrote:

Is it possible that the new update changed something and it is conflicting with my drivers?
Update won't conflicting Your Drivers... The Update only change the Game Folders content, not the OS Content too...
*Maybe as Dumie said... Change the Frame-Limiter (I suggest You choose between 60 fps Vsync or 120fps)
posted

satriobp wrote:

SolviteSekai wrote:

Is it possible that the new update changed something and it is conflicting with my drivers?
Update won't conflicting Your Drivers... The Update only change the Game Folders content, not the OS Content too...
*Maybe as Dumie said... Change the Frame-Limiter (I suggest You choose between 60 fps Vsync or 120fps)
Already did that. Also tried both opengl and directx, tried a new mouse, tried new drivers, tried lots of stuff.

Half my songs arent showing up anymore so i guess maybe ill wait for the next update and hope its a hardware conflict.
posted
Nothing has changed recently that would cause input issues. It sounds like a FPS problem or a refresh rate problem. It could also be a default driver setting. Mess around with the built in options to see if it change anything.
posted
Yeah had the same problem, i think what worked for me was to check the fullscreen mode wich apparently was unchecked without my knowing as well messing with the fps limiter.
Please sign in to reply.