forum

Solution: Running osu! In Ubuntu or Xubuntu

posted
Total Posts
943
show more
Chaosemerald

Espionage724 wrote:

I have some new notes on getting osu! to run here: https://wiki.realmofespionage.xyz/games:wine:osu

I've only tested it on Solus, but I see no reason why it wouldn't work fine on any other mainstream distro. This provides a plain install of osu! with no additional tweaking (in my experience, I've had no latency issues on the computers I've used). CJK fonts are untested (if they're broken, winetricks cjkfonts should fix that)

dotnet40 is still the only dotnet package needed (I'm still a bit curious why dotnet45 is being used by some people; does it actually solve anything?)
That's awesome! I'll definitely try it sometime on Ubuntu 16.04 when I've got time.

dotnet45 is a total pain in the arse to install (and I think it's harmful too..?) and osu! works fine with dotnet40. I don't understand why people would install dotnet45, when dotnet40 is much more easier to install
Espionage724

Chaosemerald wrote:

That's awesome! I'll definitely try it sometime on Ubuntu 16.04 when I've got time.

dotnet45 is a total pain in the arse to install (and I think it's harmful too..?) and osu! works fine with dotnet40. I don't understand why people would install dotnet45, when dotnet40 is much more easier to install
Not entirely sure if it's harmful, but I'm pretty sure it has the potential for more problems if anything. I'm not aware of anything that dotnet45 and its massive dependency set would solve that isn't provided solely with dotnet40.

Notes updated also; I keep forgetting osu! doesn't start the install on Ubuntu if it happens to be in the Downloads folder (seems to work regardless on other distros strangely). corefonts is also added (it fixes most non-Latin fonts).
grfx
Ubuntu 16 04 1
Mouse is not responsive at all ;-;
Putting the settings on Raw / absolute raw makes the mouse only move on the half of my monitor
Putting it without raw, it delays and completely randomize the speed of the cursor.
Tried both on fullscreen and windows-mode ( also with and without letterbox )
Im using a steelseries kana v2.

Is there any way to fix this?

I tried installing the driver (steelseries engine 2) through wine but didnt worked. Gave me lots of errors.
Espionage724

vroomsegway wrote:

Ubuntu 16 04 1
Mouse is not responsive at all ;-;
Putting the settings on Raw / absolute raw makes the mouse only move on the half of my monitor
Putting it without raw, it delays and completely randomize the speed of the cursor.
Tried both on fullscreen and windows-mode ( also with and without letterbox )
Im using a steelseries kana v2.

Is there any way to fix this?

I tried installing the driver (steelseries engine 2) through wine but didnt worked. Gave me lots of errors.
What GPU do you have and what drivers are you using?

If it's Intel, NVIDIA with nouveau, or AMD with open-source graphics drivers (radeon or AMDGPU), try running osu! with the environment variable vblank_mode=0

If it's NVIDIA with the proprietary driver or AMD with GPU-PRO, try figuring out some way to disable vblank/vsync (NVIDIA has an environment variable, no idea on GPU-PRO but it might share the same variable as the open-source drivers above).

Alternatively, try another distro and/or desktop enviroment (like Xubuntu or Ubuntu MATE).
Luddy
I honestly gave up after a while of trying to run osu! on any version of Ubuntu I have on any device, it was always slow and jittery. Plus it took way too much work to get it to even function at subpar 50 fps. That's when I gave up and went back to playing on Windows 10 with everything smooth. I do recommend though if you are going to be running osu! on Linux that you try using OpenGL and changing the capped framerates off of VSync (if it even is in the first place) as I find that VSync is broken in a lot of games on Linux.
Espionage724

Ludd wrote:

I honestly gave up after a while of trying to run osu! on any version of Ubuntu I have on any device, it was always slow and jittery. Plus it took way too much work to get it to even function at subpar 50 fps. That's when I gave up and went back to playing on Windows 10 with everything smooth. I do recommend though if you are going to be running osu! on Linux that you try using OpenGL and changing the capped framerates off of VSync (if it even is in the first place) as I find that VSync is broken in a lot of games on Linux.
The amount of work is pretty minimal nowadays (with the guide in my sig, you can copy/paste the lines and end up with a working set-up). osu! nowadays only has an OpenGL renderer.
SuwakoMmmh

Ludd wrote:

I honestly gave up after a while of trying to run osu! on any version of Ubuntu I have on any device, it was always slow and jittery. Plus it took way too much work to get it to even function at subpar 50 fps. That's when I gave up and went back to playing on Windows 10 with everything smooth. I do recommend though if you are going to be running osu! on Linux that you try using OpenGL and changing the capped framerates off of VSync (if it even is in the first place) as I find that VSync is broken in a lot of games on Linux.
I had the same problems as you, and the problem was wine 1.7, it's not the last version, try installing wine staging, run winecfg and in the tab "staging" check "Enable_CSMT for better graphic performance" it will allow wine to multithread. it actually gave me a 300 fps boost, hope you will have the same :b
Espionage724

dodorama wrote:

...try installing wine staging, run winecfg and in the tab "staging" check "Enable_CSMT for better graphic performance" it will allow wine to multithread. it actually gave me a 300 fps boost, hope you will have the same :b
Can you confirm this happening still? osu! nowadays should only use OpenGL (not sure if there's a fallback to D3D) and CSMT (as-documented) only affects Direct3D.
Chaosemerald
Not really related to osu!, but I just realized that the version of Wine in the Ubuntu repositories is really old (1.6.2) and I want to install latest version of Wine Staging using the official Wine PPA for Ubuntu. Will the prefixes disappear, if I uninstall Wine?
Also, osu! is apparently installed in a folder in my downloads folder. Will that go away too?
Espionage724

Chaosemerald wrote:

Not really related to osu!, but I just realized that the version of Wine in the Ubuntu repositories is really old (1.6.2) and I want to install latest version of Wine Staging using the official Wine PPA for Ubuntu. Will the prefixes disappear, if I uninstall Wine?
Also, osu! is apparently installed in a folder in my downloads folder. Will that go away too?
Nope, the prefix will be preserved if you remove and/or update Wine. If you change Wine versions, then upon osu!'s next start, you'll get a quick message about the prefix updating and then it should start.
SuwakoMmmh

Espionage724 wrote:

dodorama wrote:

...try installing wine staging, run winecfg and in the tab "staging" check "Enable_CSMT for better graphic performance" it will allow wine to multithread. it actually gave me a 300 fps boost, hope you will have the same :b
Can you confirm this happening still? osu! nowadays should only use OpenGL (not sure if there's a fallback to D3D) and CSMT (as-documented) only affects Direct3D.
Sorry, i didn't see your post because i don't check osu often. and yes, CSMT still works with osu!.
Chaosemerald

Espionage724 wrote:

Chaosemerald wrote:

Not really related to osu!, but I just realized that the version of Wine in the Ubuntu repositories is really old (1.6.2) and I want to install latest version of Wine Staging using the official Wine PPA for Ubuntu. Will the prefixes disappear, if I uninstall Wine?
Also, osu! is apparently installed in a folder in my downloads folder. Will that go away too?
Nope, the prefix will be preserved if you remove and/or update Wine. If you change Wine versions, then upon osu!'s next start, you'll get a quick message about the prefix updating and then it should start.
Oh, I see. Thanks for the reply ^^
nofacedev
Nice tutorial tho. My friend was searching this to run the game on his Ubuntu.
shiinware
I was able to install the game through PlayOnLinux :)
The fps seems to be fine also.
xiaodu_old

shiinware wrote:

I was able to install the game through PlayOnLinux :)
The fps seems to be fine also.
can you tell how to setting?
Cyber-X
Nice post, i have installed wine. but i can't connect to the internet when i'm installing osu!. can you help me?
marshallracer

Cyber-X wrote:

Nice post, i have installed wine. but i can't connect to the internet when i'm installing osu!. can you help me?
I guess we need a few more infos like specific OS and the way you installed it (straight up through wine or PoL)
I for myself had issues getting osu to run in Arch on my laptop because osu's not getting a connection for me aswell. Should've looked at the problem earlier but I didn't bother so far since it wasn't important for me to have it on there anyway
ljonka
So, after toying around with the instructions you posted here and not being able to connect to the internet as well I tried a script someone put up on GitHub
(https://www.reddit.com/r/osugame/commen ... and_other/ -> the Reddit thread)
and now everything works fine, except for the fact that I can't alt-tab out of osu! and if I try the window freezes and I have to kill the process in another console.

Despite the alt-tab-freeze I tried to play and I experienced some lag. It wasn't that much but definitely noticeable (I play around 2.5-3.5 star maps). I set FPS to unlimited, running on Full-screen (1920x1080) but it's persistent whatever I do.

Edit: After enabling multi-threading and setting the osu! window to borderless windowed most of the lag is gone and it runs really smooth
Chaosemerald
is it just me or has anyone else also experienced that the circles and sliders appear way too early, which makes it pretty hard to play?
I have to set my universal offset to 64ms and local offset to 95ms in order to make the objects and hitsounds appear correctly in time with the music :<
Raging Ray

Chaosemerald wrote:

is it just me or has anyone else also experienced that the circles and sliders appear way too early, which makes it pretty hard to play?
I have to set my universal offset to 64ms and local offset to 95ms in order to make the objects and hitsounds appear correctly in time with the music :<
Offset seems fine for me.

Did that happen somewhere else as well?
If yes and you are using Pulseaudio, this might be the problem.
You could try to deactivate it and just use the Alsa Mixer.
Chaosemerald

Raging Ray wrote:

Offset seems fine for me.

Did that happen somewhere else as well?
If yes and you are using Pulseaudio, this might be the problem.
You could try to deactivate it and just use the Alsa Mixer.
I don't have that problem anywhere else, not even in the other Wine games.
But I'll try to deactivate PulseAudio anyway and see if it does anything c:
Chaosemerald
I don't know how to disable PulseAudio in Ubuntu, but then I found about pasuspender, which apparently is a pretty neat utility for disabling PulseAudio temporarily

But if I'm going to use pasuspender in terminal, am I going to type this:
pasuspender -- WINEPREFIX=~/.wineosu wine ~/osu/"osu!".exe
or this:
WINEPREFIX=~/.wineosu pasuspender -- wine ~/osu/"osu!".exe


Edit: Nevermind, I'm going to get rid of Ubuntu soon and install Debian anyway, so I don't want to spend time on that
ioneccc
Thank you for the guide
I would be really glad tho to see a native linux build in the future
Chaosemerald

ioneccc wrote:

Thank you for the guide
I would be really glad tho to see a native linux build in the future
There is actually coming a native Linux port! I think it'll be released, when osu!next gets released
Alysia
Does anyone have any tips on running osu! on GNOME/Kali Linux?
TinC
Hey, have mint kde x64, but osu client from playonlinux app run only in x32. How can I fix this and run x64 version? Teach me, senpai.
marshallracer

TinC wrote:

Hey, have mint kde x64, but osu client from playonlinux app run only in x32. How can I fix this and run x64 version? Teach me, senpai.
Basically, there's a in-depth, up-to-date guide over here
There are sections on creating 32-Bit Wine prefixes for various conditions such as either using pre-existing or self-compiled wine versions
If you want to get it working as easily as possible I guess taking the PlayOnLinux route is your best bet but you're given various options (papa bless Franc[e]sco for all of his efforts of making and updating his guide)
Stray Lamb2
I've been playing on Linux Xubuntu 16.04 in PlayOnLinux for a month or two now, stable fps, no tearing, same latency as windows, minor visual issues with settings side panel and non-latin letters. If you check my latest scores, given my skill level, it is the same as my pre-linux scores. So, with that as a metric, you could say it is the same exact experience.

How I got it running is simple:
- Make a new PoL drive (x32), with wine 2.0-rc3-staging (x32).

- Configure->Miscellaneous->Open a shell

- Enter the following (one at a time) :

Install newest winetricks:
  wget  https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
chmod +x winetricks

Install vcrun2015
sh winetricks vcrun2015

- Go to the "Install components" tab, install dotnet40

- Miscellaneous tab once again, "Run a .exe file in this virtual drive"

- Run your osu! installer

- Play the game

Hope it works for you too, didn't post up until now to test functionality.
CodeNameT1M
just found this post and i also got osu! to run, but it doesn't connect to Bancho

osu 20170616 (latest)
wine 2.11
manjaro linux 17.0.2
dotnet 4.5 installed

if someone else had this problem and know how to fix that i would appreciate it if you help me ^^
marshallracer

DJT1M wrote:

just found this post and i also got osu! to run, but it doesn't connect to Bancho

osu 20170616 (latest)
wine 2.11
manjaro linux 17.0.2
dotnet 4.5 installed

if someone else had this problem and know how to fix that i would appreciate it if you help me ^^
From this Thread

SanteriP wrote:

Fixed it by installing lib32-gnutls and lib32-gnutls26 (not sure which one because I installed both at once, lol). Also installed libgnutls. The game is running! Wonderful.
Ambrew
Hi, Does this work on Lubuntu 15.04 Vivid on a i386 (32-bit) architecture? Thanks!

EDIT: Looking through the guide I came across this...

6. Download osume.exe
Terminal > wget http://osu.ppy.sh/release/osume.exe
This link leads to an HTTP 404 Not Found Error. Can someone post an updated link?
marshallracer

Ambrew wrote:

This link leads to an HTTP 404 Not Found Error. Can someone post an updated link?
I would instead follow the guide on t/367783
It's up-to-date and gives you varying ways to install osu


To this date I wonder why the other thread isn't stickied yet >:(
roblox
Could you make a version for Lubuntu?? Thanks :)
TheRealVinite
On osu! Updater it says ‘An error occurred! Please check your internet connection.’ How do I fix this problem?
Kazutoy
works fine on debian
gansta
you internet or wifi is slow :shock: ? :D;)
kiran
"An error occurred! Please check your internet connection" while installing osu
Stray Lamb2
@kiran install lib32nss-mdns. Wine has some issues with net connection while it isn't installed.
So, open a terminal and (assuming you've got a debian/ubuntu/mint distro) type
sudo apt install lib32nss-mdns
kiran

Stray Lamb2 wrote:

@kiran install lib32nss-mdns. Wine has some issues with net connection while it isn't installed.
So, open a terminal and (assuming you've got a debian/ubuntu/mint distro) type
sudo apt install lib32nss-mdns
still the same -> this is on debian
on ubuntu osu updater keeps restarting over and over again
Kilo-Five
>~< I broke it...

kilo-five@Kilo-Five-Base ~ $ WINEARCH=win32 winecfg
wine: WINEARCH set to win32 but '/home/kilo-five/.wine' is a 64-bit installation.
kilo-five@Kilo-Five-Base ~ $ winetricks dotnet20
The program 'winetricks' is currently not installed. You can install it by typing:
sudo apt install winetricks
kilo-five@Kilo-Five-Base ~ $ sudo apt install winetricks
[sudo] password for kilo-five:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
winetricks
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 132 kB of archives.
After this operation, 792 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu xenial/universe amd64 winetricks all 0.0+20141009+svn1208-2ubuntu1 [132 kB]
Fetched 132 kB in 2s (60.1 kB/s)
Selecting previously unselected package winetricks.
(Reading database ... 211989 files and directories currently installed.)
Preparing to unpack .../winetricks_0.0+20141009+svn1208-2ubuntu1_all.deb ...
Unpacking winetricks (0.0+20141009+svn1208-2ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22+linuxmint1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up winetricks (0.0+20141009+svn1208-2ubuntu1) ...
kilo-five@Kilo-Five-Base ~ $ winetricks dotnet20
------------------------------------------------------
You are using a 64-bit WINEPREFIX. If you encounter problems, please retest in a clean 32-bit WINEPREFIX before reporting a bug.
------------------------------------------------------
Executing w_do_call dotnet20
Executing load_dotnet20
Executing mkdir -p /home/kilo-five/.cache/winetricks/dotnet20
Downloading http://download.lenovo.com/ibmdl/pub/pc/pccbbs/thinkvantage_en/dotnetfx.exe to /home/kilo-five/.cache/winetricks/dotnet20
--2018-05-24 11:17:22-- http://download.lenovo.com/ibmdl/pub/pc/pccbbs/thinkvantage_en/dotnetfx.exe
Resolving download.lenovo.com (download.lenovo.com)... 23.205.215.148
Connecting to download.lenovo.com (download.lenovo.com)|23.205.215.148|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://download.lenovo.com/ibmdl/pub/pc/pccbbs/thinkvantage_en/dotnetfx.exe [following]
--2018-05-24 11:17:25-- https://download.lenovo.com/ibmdl/pub/pc/pccbbs/thinkvantage_en/dotnetfx.exe
Connecting to download.lenovo.com (download.lenovo.com)|23.205.215.148|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 23510720 (22M) [application/octet-stream]
Saving to: ‘dotnetfx.exe’

dotnetfx.exe 100%[===================>] 22.42M 220KB/s in 95s

2018-05-24 11:19:01 (241 KB/s) - ‘dotnetfx.exe’ saved [23510720/23510720]

Executing w_do_call remove_mono
Executing load_remove_mono
------------------------------------------------------
Mono does not appear to be installed.
------------------------------------------------------
Executing w_do_call fontfix
Executing load_fontfix
Setting Windows version to win2k
Executing winetricks_early_wine regedit C:\windows\Temp\_dotnet20\set-winver.reg
------------------------------------------------------
Working around wine bug 34803
------------------------------------------------------
DELETE - HKLM\Software\Microsoft\.NETFramework\v2.0.50727\SBSDisabled (null) 0 0 0
Error: The system was unable to find the specified registry key or value
Current wine does not have wine bug 30845, so not applying workaround
Executing wine dotnetfx.exe
fixme:advapi:DecryptFileA ("C:\\users\\kilo-five\\Temp\\IXP000.TMP\\", 00000000): stub
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:advapi:LsaOpenPolicy ((null),0x33f2cc,0x00000001,0x33f2c0) stub
fixme:advapi:LsaClose (0xcafe) stub
------------------------------------------------------
Note: command 'wine dotnetfx.exe' returned status 66. Aborting.
------------------------------------------------------
kilo-five@Kilo-Five-Base ~ $ WINEARCH=win32 winecfg
wine: WINEARCH set to win32 but '/home/kilo-five/.wine' is a 64-bit installation.
kilo-five@Kilo-Five-Base ~ $
show more
Please sign in to reply.

New reply