Solution: Running osu! In Ubuntu or Xubuntu

posted
Total Posts
938
show more
SpacemanSpiff

SatoXYN wrote:

Segfault because of PulseAudio, don't use it. Try swithing to OSS, and if no luck, uninstall PulseAudio and use pure Alsa.
It's also a good idea to use OSS or ALSA simply because of some issues across programs and operations trying to use the same driver. I have to use aoss as a prefix for many operations because my system likes to only give sound to one program. Also like before, if you do this, tell winetricks to change to ALSA or OSS, don't use winecfg if you are familiar with it, my sound failed to work until I had winetricks force the change rather than winecfg. You will, however, need to use winecfg to confirm that sound works with the ''test sound'' button.

Alsp, I'm not sure if you have to tell config that osu!.exe or osume.exe has to run under Windows XP in order to avoid an issue I ran into before where it would say I would need to give administrator privileges. Those are minor compared to getting osu! up and running, though.
SatoXYN

mrmike503 wrote:

It's also a good idea to use OSS or ALSA simply because of some issues across programs and operations trying to use the same driver. I have to use aoss as a prefix for many operations because my system likes to only give sound to one program.
That's because you have no dmix and sound is not mixing.
eMkay
i still don't get it working -.-
Direct Rendering is enabled so no problem with that.
But it really seems that it's just the sound driver.
I already uninstalled PulseAudio using "sudo apt-get remove pulseaudio" and installed OSS instead.
I also defaulted sound to OSS and disabled ALSA.
I used winetricks to set sound to OSS and the sound test works fine
Well now osu! starts but i always get the Error Screen from osu! with that pippi thing.
SpacemanSpiff

eMkay wrote:

i still don't get it working -.-
Direct Rendering is enabled so no problem with that.
But it really seems that it's just the sound driver.
I already uninstalled PulseAudio using "sudo apt-get remove pulseaudio" and installed OSS instead.
I also defaulted sound to OSS and disabled ALSA.
I used winetricks to set sound to OSS and the sound test works fine
Well now osu! starts but i always get the Error Screen from osu! with that pippi thing.
Did you try ALSA instead? I don't know if your system automatically configured to your sound card, but maybe that needs to be updated too. I never have that issue because I don't get sound until I manually set it up.

Also thanks for the dmix tip sato, I think I've run into the issue even if dmix is set up. I had it happen before in Ubuntu when I used to use it. Arch has you set up everything manually, so I did what I knew best for a workaround. :lol:
eMkay
Nvm it was just a try ;)
Maybe someone will somewhen make a script for PlayOnLinux and you don't have to do anything anymore :D
SatoXYN
Try this russian manual via google translate
http://translate.google.ru/translate?js ... %3D69589.0
SpacemanSpiff

eMkay wrote:

Nvm it was just a try ;)
Maybe someone will somewhen make a script for PlayOnLinux and you don't have to do anything anymore :D
Just a quick question, are you on a 64 bit distro (and you said Ubuntu, right?)? I might be able to try setting it up using that distro in a few weeks when I get a new hard drive. Also do you use an ATI or nVidia video card? I wanna see if I can be of more help.

It would be a good idea for me to attempt a fresh "out-of-the-box" installation to see if I can get osu! running on a fresh install of Arch Linux or Ubuntu. (I don't know what else other people use, but I saw a bunch of Ubuntu posts and one other Arch). I can post results and see if anything works easily. Sadly, I won't be as reliable with the Arch Linux installation in a week or so, it's my primary computer when the parts arrive, and I need to compile anything and everything useful. I can try doing it early on, however.
Thunderwolf1989
Hey.

Tried to do this for Wolvix (=Slackware based) and most of it works fine: Installed nvidia drivers, wine, winetricks etc. (use slapt-get --install instead of apt-get) Installed osu! went good as well, but although I'm able to play (at least the test map) and update the game, I can't login...
SpacemanSpiff

Thunderwolf1989 wrote:

Hey.

Tried to do this for Wolvix (=Slackware based) and most of it works fine: Installed nvidia drivers, wine, winetricks etc. (use slapt-get --install instead of apt-get) Installed osu! went good as well, but although I'm able to play (at least the test map) and update the game, I can't login...
Are you getting terminal errors? Try seeing if you can fish out some errors from a terminal when you attempt to log on. My only other idea might be to get gecko via winetricks, but I think that was only something I needed.

I can confirm this all works on Arch64 on the source-based wow64-wine. I will say though, if you try this, odds are you are going to have one hell of a time trying to get net 2.0 up and running. Once you get there, it's a walk in the park, really. It took me a whopping 3 hours of mind grinding just to get net 2.0 working, but it's shocking how much better this runs on my Linux rig than it does my laptop.

As for anyone trying out osu! on Linux, do not use opengl. I actually crash with opengl (including the -opengl modifier on the end of the command). As far as I know right now, the guide compilation I made should work for most main distros. The only thing I might change is that you get gecko from winetricks before even attempting to get net 2.0 or at least getting gecko.
Thunderwolf1989
osu! gives me a unhandled exception showing "Not implemented"

Rest of the message:
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NotImplementedException: Not implemented.
at System.Drawing.Region.GetRegionScans(Matrix matrix)
at System.Windows.Forms.LinkLabel.OnPaint(PaintEventArgs e)
at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer, Boolean disposeEventArgs)
at System.Windows.Forms.Control.WmPaint(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Label.WndProc(Message& m)
at System.Windows.Forms.LinkLabel.WndProc(Message& msg)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
osu!
Assembly Version: 1.3.3.7
Win32 Version: 1.3.3.7
CodeBase: file:///C:/Program%20Files/osu!/osu!.exe
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
osu
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Program%20Files/osu!/osu.DLL
----------------------------------------
Microsoft.Xna.Framework
Assembly Version: 1.0.0.0
Win32 Version: 1.1.10405.0
CodeBase: file:///C:/Program%20Files/osu!/Microsoft.Xna.Framework.DLL
----------------------------------------
msvcm80
Assembly Version: 8.0.50608.0
Win32 Version: 8.00.50727.42
CodeBase: file:///C:/windows/winsxs/x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.42_x-ww_0de06acd/msvcm80.dll
----------------------------------------
System.Runtime.Remoting
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
Microsoft.Ink
Assembly Version: 1.7.2600.2180
Win32 Version: 1.7.2600.2181
CodeBase: file:///C:/Program%20Files/osu!/Microsoft.Ink.DLL
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
dynamicBASSNET
Assembly Version: 0.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Program%20Files/osu!/osu.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.42 (RTM.050727-4200)
CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
{c73083cc-7aff-481b-b2e6-7b02fa7f7bbd}
Assembly Version: 0.0.0.0
Win32 Version: 1.3.3.7
CodeBase: file:///C:/Program%20Files/osu!/osu!.exe
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

And this is what's in the terminal:
fixme:ntdll:server_ioctl_file Unsupported ioctl 24000 (device=2 access=1 func=0 method=0)
fixme:actctx:parse_manifest_buffer root element is L"asmv1:assembly", not <assembly>
fixme:sync:CreateMemoryResourceNotification (0) stub
fixme:shell:URL_ParseUrl failed to parse L"System"
fixme:shell:URL_ParseUrl failed to parse L"System.Windows.Forms"
fixme:shell:URL_ParseUrl failed to parse L"System.Drawing"
fixme:shell:URL_ParseUrl failed to parse L"osu"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework"
fixme:shell:URL_ParseUrl failed to parse L"msvcm80"
fixme:shell:URL_ParseUrl failed to parse L"System.Runtime.Remoting"
fixme:process:SetProcessPriorityBoost (0x198,0): stub
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x1a6c10,0x1a6b10): stub
fixme:mmdevapi:AEV_GetVolumeRange stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33ce9c,0x00000000), stub!
fixme:d3d:swapchain_init Add OpenGL context recreation support to context_validate_onscreen_formats
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Ink"
fixme:shell:URL_ParseUrl failed to parse L"osu.resources"
fixme:shell:URL_ParseUrl failed to parse L"System.Configuration"
fixme:shell:URL_ParseUrl failed to parse L"System.Xml"
fixme:gdiplus:GdipCreateHalftonePalette stub
fixme:shell:URL_ParseUrl failed to parse L"{c73083cc-7aff-481b-b2e6-7b02fa7f7bbd}"
fixme:shell:URL_ParseUrl failed to parse L"osu!.resources"
fixme:gdiplus:GdipGetFamilyName No support for handling of multiple languages!
fixme:gdiplus:GdipGetRegionScansCount not implemented
fixme:shell:URL_ParseUrl failed to parse L"System.Drawing.resources"
fixme:shell:URL_ParseUrl failed to parse L"System.Windows.Forms.resources"
fixme:shell:URL_ParseUrl failed to parse L"mscorlib.resources"
fixme:thread:NtQueryInformationThread info class 16 not supported yet

I think it's something about this line:
fixme:gdiplus:GdipGetRegionScansCount not implemented

I can click the continue button in the dialog and play as guest completely fine.

EDIT: Seems it's fixed already by installing the gdiplus libraries (sh winetricks gdiplus) :lol:
SpacemanSpiff
I updated my post on page 6 with a bit more accurate detail and added some errors I've encountered before. I don't know of any other errors at this point, but I hope my error fixes are a good starting point.
Thunderwolf1989
Okay, that font smoothing thingy is what's responsible for those texts in the lower right corner then? Ok, will add that as well.

Oh, and do you all have problems with the osu! installer? I could just run that installer normally, no crashes or anything. Installing went fine here. I must say though that I have a few other games as well, which might have installed something themselves (vcredist's, perhaps a few directx things etc.)
SpacemanSpiff

Thunderwolf1989 wrote:

Okay, that font smoothing thingy is what's responsible for those texts in the lower right corner then? Ok, will add that as well.

Oh, and do you all have problems with the osu! installer? I could just run that installer normally, no crashes or anything. Installing went fine here. I must say though that I have a few other games as well, which might have installed something themselves (vcredist's, perhaps a few directx things etc.)
I never really tried, I'm sure it would work fine. I just suggest taking a pre-installed osu! because there might be more errors that come up. If you'd like to do a handful of installations and find out the possible errors, though, be my guest. :lol:

Hopefully some other people can confirm that this works on Ubuntu, Arch or other popular distros.
HarryHy
I am running Arch x86_64 right now.

I managed to get it running after Arch's painful multilib setup... but none of the menus have any text, and it initially crashes with .NET errors.
sh winetricks gdiplus fixed it.

If I keep it at horrible slow DirectX video, it works.
If I change to OpenGL, I get:
err:module:load_builtin_dll failed to load .so lib for builtin L"winemp3.acm": libmpg123.so.0: cannot open shared object file: No such file or directory
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x2147d8,0x214720): stub
fixme:mmdevapi:AEV_GetVolumeRange stub
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 154 (GLX)
Minor opcode of failed request: 11 (X_GLXSwapBuffers)
Serial number of failed request: 1332
Current serial number in output stream: 1332

What to try now?
miikkak
I'm currently running Kubuntu and I have problems with my mouses peed in Osu!

My mouse lags insanely if i put mouse speed to anything that differs from 1,0x. Has onyone experiencing the same problem?
SpacemanSpiff

miikkak wrote:

I'm currently running Kubuntu and I have problems with my mouses peed in Osu!

My mouse lags insanely if i put mouse speed to anything that differs from 1,0x. Has onyone experiencing the same problem?


It's been a while since I set up my Wine for osu! now, but most of the things in my post on page 6 list everything for Arch, which I find a tad more picky than debian-based distros. Odds are you are missing something outside gecko or dotnet20 (which are required). Try winetricking these few things.

sh winetricks fontfix fontsmooth-rgb gdiplus

Let me know if it's still choppy, because then it may be a faulty configuration in your ~/.wine.

The other tip is make sure you run wine with alsa audio. If that still chops it, see if running it with aoss as a prefix to the wine command will fix it (ex. aoss wine /path/to/directory/osu!.exe).

Edit: Just to clarify, the reason I'm suggesting this is because wine chops up trying to translate some of the coding in osu!. With these, most lag issues tend to go away.

HarryHy wrote:

I am running Arch x86_64 right now.

I managed to get it running after Arch's painful multilib setup... but none of the menus have any text, and it initially crashes with .NET errors.
sh winetricks gdiplus fixed it.

If I keep it at horrible slow DirectX video, it works.
If I change to OpenGL, I get:
err:module:load_builtin_dll failed to load .so lib for builtin L"winemp3.acm": libmpg123.so.0: cannot open shared object file: No such file or directory
fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x2147d8,0x214720): stub
fixme:mmdevapi:AEV_GetVolumeRange stub
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 154 (GLX)
Minor opcode of failed request: 11 (X_GLXSwapBuffers)
Serial number of failed request: 1332
Current serial number in output stream: 1332

What to try now?


Definitely go look at my post on page 6. I'm currently also running an x64_86 Arch build and I did exactly what my post said and it worked just fine. If you get a couple more errors, check my few fixes at the bottom of my post.
Baspar
libmpg123.so.0: cannot open shared object file: No such file or directory

We can solve easily this error. In temrinal, do "sudo updatedb" ( If you have installed Sudo ,otherwise tape " updatedb" only ) and " locate libmpg123.so" and post here the return.

But Opengl doesn't work, play only with DirectX.
If you don't want reinstall it, remove the file osu!.yourname.cfg in osu's folder

@miikkak: well, I've same trouble, but i play on 1x speed ^^' TRy with "sudo xset m X Y " ( choose X and Y like this: if you move your cursor for more than X pixels, multiply speed per Y)
ELEKA22
Hi, I have tried to install Osu! ubuntu 1 month, I could do, uninstalling ubuntu 3 times. But now that I installed (with problems in "Publishing Information") to achieve open (Direct3D only) without major graphics problems. Except that when I try to play, the music does not sound and when I skip, the top bar is intact it does not matter, I can move, etc. But it is strange :( .

PD: My problem is that the circles do not then appear (or fruits, etc), I mean the game is stopped :| .

My Pc:
Ubuntu :) 10.10 Amd Athlon (I use Wine for Ubuntu)
ATI Radeon X1200 Series
1GB RAM ....
Wine: 1.2.1 (peer outdated) :D

HEEEEEEELP!

Translate by Google Translate (Spanish > English)
anonymous_old
OSU! IS NOT SUPPORTED ON UBUNTU. If it doesn't work, it doesn't work.
ELEKA22

strager wrote:

OSU! IS NOT SUPPORTED ON UBUNTU. If it doesn't work, it doesn't work.
ok, not supported, but may be, there is a page of Osu! in WineHQ.org that has no administrator, perhaps a programmer to make a port.

Q.Q
show more
Please sign in to reply.

New reply