forum

Solution: Running osu! In Ubuntu or Xubuntu

posted
Total Posts
941
show more
Haruhiist
Will try to.
P.S. Yea. 3 days ago i switched from Ubuntu to Arch. Looks way better. Wine is working faster.
Haruhiist
Cannot install osu. shows up error. Yes, i have .net framework installed, I'm unable to install game.
Ziggy Zigzagoon

Uber1337 wrote:

Works fine, no lags(Kubuntu) but all fonts are realy sharp =( (Does some1 kno' how to fix Opengl?!)
Also:no background images in beatmap list =(
Excuse me, but how did you get osu! to run under Kubuntu? I tried doing a lot of things in order to get osu! running under Kubuntu, but...
Tasem
I'd like to note that I've tried both the prepare-osu.sh here and the initial setup process in the first post and neither seems to work for me(I'm on Ubuntu Lucid, by the way). The main problem seems to be during install where it cancels out with something about a publishing error. I once tried to move my windows osu! over to ubuntu but all it got me was the ability to open the Osu! updater, not osu itself. I'm about to try again since I just got my new tablet to work, so we'll see how it goes
Crakila
On Lucid (10.04) you have to check a box in order to install osu!

You right-click the exe and click "Properties", Go to the "Permissions" tab and check the "Allow executing file as program", Click "Close" and then right-click the file again and launch with Wine.

That's what I did and it installed perfectly.
Tasem
Really? I wasn't aware of that. Though I just did it and it failed anyway, but I noticed that even after reinstall Wine!, Osu was still in some fashion installed(the version number was 0.0.0.0, which is nothing new but I can't seem to figure out how to uninstall it, since it also crashes when I try to remove it via wine). Is there any way to clear out wine's registration of Osu somehow, so that it can start the install fresh?

--EDIT: I feel a bit closer to success. After reinstalling wine clean and removing osu entirely, I reinstalled it and it still failed when trying to publish it's product information. Now, however, after changing the windows version to 7/Vista, I get this specific error instead of the generic crash:

Application has generated an exception that could not be handled.

Process ID=0x29(41), Thread ID=0x2(42).
If I click cancel to try to debug it, I get:

No registered JIT debugger was specified.

EDIT EDIT: http://pastebin.com/n9ZVwRwx it ocurred to me to try to run the installer through the terminal so I could get the error logs of whatever's wrong. It's pretty much gibberish to me but somebody might be able to make heads or tails out of it?
embolalia
Ubuntu 10.04, amd64

The installer fails at what looks like the end of the process. Instead, I just went to my Windows install directory (I dual-boot) and ran from there. It slows everything waaaaayyyy down, using what looks to be all of one of my two cores. If I wait long enough, it turns the whole screen gray. (I'm guessing that since it was set for full-screen mode in Windows, that's what that is). It doesn't seem to do anything else, and I have to kill it. I've already tried changing to OpenGL in the .cfg file. Any suggestions?
bagnz0r

rpr13 wrote:

-> Haruhiist
Do as root:
chown -R [username]:[usergroup] /home/[username]/.wine/

PS. Arch is da best xD
NOT.
Tasem
http://pastebin.com/n9ZVwRwx

can't anyone tell me what's wrong here? ;w; I'm really missing Osu maan
bagnz0r

Tasem wrote:

http://pastebin.com/n9ZVwRwx

can't anyone tell me what's wrong here? ;w; I'm really missing Osu maan
#
fixme:advapi:RegisterEventSourceW ((null),L".NET Runtime"): stub
#
fixme:advapi:ReportEventW (0xcafe4242,0x0001,0x0000,0x000003ff,(nil),0x0001,0x00000000,0x33eba8,(nil)): stub
#
err:eventlog:ReportEventW L".NET Runtime version 2.0.50727.42 - Fatal Execution Engine Error (79F97075) (80131506)"
#
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
#
err:msi:ITERATE_Actions Execution halted, action L"InstallFinalize" returned 1627
#
err:msi:ITERATE_Actions Execution halted, action L"ExecuteAction" returned 1627

That'd be .NET.
But why don't you try running osu! in VM? Using VirtualBox, that is.
I get avg. 140fps on P4 3GHz, 2GB DDR2 and some nvidia mx.
MapleAwesome12
Hello, Osu! community. After playing in a netgame on another game, and learning of another person playing Osu! I was immediately tempted to see if it would launch on WINE. Nope. I've tried ALL of your info on this. I've tried the first tutorial, I've tried the wget bagznor thing, and there hasn't been any success. The first thing I encountered was the Osu!Install downloading the .NET 2.0 (as the cabextract didn't succeed in downloading a .NET installer) and the .NET installer comes up. I try to install, and it fails. It continues to the Osu! installer. I get it to install up to "Publishing product information" and it gives the Windows Crash Dialog and then the WINE crash dialog. None of this is working. I'd like to play Osu! as soon as possible, as I have songs on my Secondary drive back when I played it on Windows. When exactly will this game work on Linux WITHOUT use of desktop emulators?

BTW, VirtualBox doesn't work. It stops at mid-bootup, so no success there.
Tasem
The main problem seems to be installing dotnet or getting it to run or /someting/ i dunno wut. I'm currently playing it on Virtualbox but JUST TODAY out of nowhere I got the window to run on Wine! The problem is that it died and hasnt opened again. Right now I'm trying to reinstall dotnet2.0 but i dont know what ive done or havent done that will make it work.

You can run it on Virtualbox but even with a whole gig of ram practically given to virutalbox, and all my video memory, I get occasional framerate issues and the sound crackles. They're enough to make the game frustrating to play, to say the least.
bagnz0r

Tasem wrote:

The main problem seems to be installing dotnet or getting it to run or /someting/ i dunno wut. I'm currently playing it on Virtualbox but JUST TODAY out of nowhere I got the window to run on Wine! The problem is that it died and hasnt opened again. Right now I'm trying to reinstall dotnet2.0 but i dont know what ive done or havent done that will make it work.

You can run it on Virtualbox but even with a whole gig of ram practically given to virutalbox, and all my video memory, I get occasional framerate issues and the sound crackles. They're enough to make the game frustrating to play, to say the least.
Change sound driver in vm settings.
Tasem
?_? To what, exactly? I'm currently using OSS, but I don't know what's considered to be the optimal one, and OSS /seemed/ to work the best.
joaowojcikiewicz
I can't run osu! on linux here.
I have installed dotnetfx 20 and 30, all required fonts and osu crash.
Sometimes, when I click a lot of times in Restart osu, it start, but everytime when I choose a song, the audio automatically mute and the music won't load.
What I have to do to make it work?

Tasem
Okay, so yesterday I reinstalled Linux Mint, in preparation for my new RAM. I'm now running Isadora Gnome x64bit, and I installed Wine rc6 from the wine ppa. I got winetricks, installed gecko, and then installed the following:
corefonts
some corefonts smoothing files(normal smoothing and grayscale, I believe)
dotnet20

Then I tried for Osu again. the installer ran and failed at publishing like always, and I pretty much gave up right then and there, but to my surprise, Osu is opening consistently in direct3d mode when I run it on wine!

If I switch it to opengl mode, it breaks and will not open.

However, all is not well; on occasion the sound just dies out of nowhere, even after I configured wine to actually use an audio driver, which I hadn't done yet. Even if it doesn't, when I start a beatmap(so far tested with Full Metal Alchemist Rewrite), the game/beatmap freezes. I can hit escape and go back to the osu! menu but the sound will invariably be dead. Additionally, there are a few things that aren't rendered, like the boxes that cover the resolution settings in options and the text inside the little bubbles that show up for updates.

Also, I was able to sign into my account, that wasn't an issue surprisingly.

Could the problem be because I installed Directx10 and not...nine, or something? I'm scared to tamper with this too much more in case I do something stupid and break it all over again. I hope someone can help me here, thanks
joaowojcikiewicz

Tasem wrote:

Okay, so yesterday I reinstalled Linux Mint, in preparation for my new RAM. I'm now running Isadora Gnome x64bit, and I installed Wine rc6 from the wine ppa. I got winetricks, installed gecko, and then installed the following:
corefonts
some corefonts smoothing files(normal smoothing and grayscale, I believe)
dotnet20

Then I tried for Osu again. the installer ran and failed at publishing like always, and I pretty much gave up right then and there, but to my surprise, Osu is opening consistently in direct3d mode when I run it on wine!

If I switch it to opengl mode, it breaks and will not open.

However, all is not well; on occasion the sound just dies out of nowhere, even after I configured wine to actually use an audio driver, which I hadn't done yet. Even if it doesn't, when I start a beatmap(so far tested with Full Metal Alchemist Rewrite), the game/beatmap freezes. I can hit escape and go back to the osu! menu but the sound will invariably be dead. Additionally, there are a few things that aren't rendered, like the boxes that cover the resolution settings in options and the text inside the little bubbles that show up for updates.

Also, I was able to sign into my account, that wasn't an issue surprisingly.

Could the problem be because I installed Directx10 and not...nine, or something? I'm scared to tamper with this too much more in case I do something stupid and break it all over again. I hope someone can help me here, thanks
Same to me :cry:
Tasem
Update:: So far, my fascinating adventures through the hidden lands of wine have brought me little fruit. On the one hand, I can consistently get Osu running at the same level as I described even after a total system reinstall. On the other, Osu still isn't functional and I still dont know whats wrong exactly. I am sure that I must be missing some other dependencies that havent been mentioned, but as to what they are..well, it isn't directx, anyway, I'm running 9 now and no dice. Also, I tried to install dotnet20sp2 and the installation failed. Could that be where the problem lies?
bagnz0r

Tasem wrote:

?_? To what, exactly? I'm currently using OSS, but I don't know what's considered to be the optimal one, and OSS /seemed/ to work the best.
...And it's exactly OSS.
SatoXYN
Hey! I've got osu working on my PC! But is starts only 1 time on 10.
You have to install everything what in 1 message in this topic, and I also installed something with fonts.
Run it with nice!
nice -n 19 wine /path/to/osu!.exe
When you got only windows exception(!) you can play as much as you want, don't press OK or CANCEL there! Just hide!
http://habreffect.ru/77c/d8ad5f3a5/%D0% ... %D0%BA.png
SatoXYN
Osu! is running ABSOLUTELY as it should with the latest wine 1.2rc7 now!
If not, try to get newer mscorlib for dotnet 2.0
awp

SatoXYN wrote:

http://habreffect.ru/77c/d8ad5f3a5/%D0%A1%D0%BD%D0%B8%D0%BC%D0%BE%D0%BA.png
this image link crashes my computer does it crash anybody else's?
Noobita

awp wrote:

SatoXYN wrote:

http://habreffect.ru/77c/d8ad5f3a5/%D0%A1%D0%BD%D0%B8%D0%BC%D0%BE%D0%BA.png
this image link crashes my computer does it crash anybody else's?
Not mine... that's very weird maybe because there is russian in it? (just a guess)
joaowojcikiewicz

Tasem wrote:

Okay, so yesterday I reinstalled Linux Mint, in preparation for my new RAM. I'm now running Isadora Gnome x64bit, and I installed Wine rc6 from the wine ppa. I got winetricks, installed gecko, and then installed the following:
corefonts
some corefonts smoothing files(normal smoothing and grayscale, I believe)
dotnet20

Then I tried for Osu again. the installer ran and failed at publishing like always, and I pretty much gave up right then and there, but to my surprise, Osu is opening consistently in direct3d mode when I run it on wine!

If I switch it to opengl mode, it breaks and will not open.

However, all is not well; on occasion the sound just dies out of nowhere, even after I configured wine to actually use an audio driver, which I hadn't done yet. Even if it doesn't, when I start a beatmap(so far tested with Full Metal Alchemist Rewrite), the game/beatmap freezes. I can hit escape and go back to the osu! menu but the sound will invariably be dead. Additionally, there are a few things that aren't rendered, like the boxes that cover the resolution settings in options and the text inside the little bubbles that show up for updates.

Also, I was able to sign into my account, that wasn't an issue surprisingly.

Could the problem be because I installed Directx10 and not...nine, or something? I'm scared to tamper with this too much more in case I do something stupid and break it all over again. I hope someone can help me here, thanks
I have found a solution for this problem. Open Wine configuration, go to Audio tab and switch Hardware Acceleration to Emulated. It should work now
Tasem

joaowojcikiewicz wrote:

Tasem wrote:

Okay, so yesterday I reinstalled Linux Mint, in preparation for my new RAM. I'm now running Isadora Gnome x64bit, and I installed Wine rc6 from the wine ppa. I got winetricks, installed gecko, and then installed the following:
corefonts
some corefonts smoothing files(normal smoothing and grayscale, I believe)
dotnet20

Then I tried for Osu again. the installer ran and failed at publishing like always, and I pretty much gave up right then and there, but to my surprise, Osu is opening consistently in direct3d mode when I run it on wine!

If I switch it to opengl mode, it breaks and will not open.

However, all is not well; on occasion the sound just dies out of nowhere, even after I configured wine to actually use an audio driver, which I hadn't done yet. Even if it doesn't, when I start a beatmap(so far tested with Full Metal Alchemist Rewrite), the game/beatmap freezes. I can hit escape and go back to the osu! menu but the sound will invariably be dead. Additionally, there are a few things that aren't rendered, like the boxes that cover the resolution settings in options and the text inside the little bubbles that show up for updates.

Also, I was able to sign into my account, that wasn't an issue surprisingly.

Could the problem be because I installed Directx10 and not...nine, or something? I'm scared to tamper with this too much more in case I do something stupid and break it all over again. I hope someone can help me here, thanks
I have found a solution for this problem. Open Wine configuration, go to Audio tab and switch Hardware Acceleration to Emulated. It should work now
Oh my God, it works now! A hundred thanks, joao!

Remaining bugs: the notification texts dont work properly, and some text boxes in the options screen also seem to be missing. Also, in the skin selection screen you can't see the base slider/beats, only the hit effects and slider balls, ectetera. However the game seems playable.
joaowojcikiewicz

Tasem wrote:

Oh my God, it works now! A hundred thanks, joao!

Remaining bugs: the notification texts dont work properly, and some text boxes in the options screen also seem to be missing. Also, in the skin selection screen you can't see the base slider/beats, only the hit effects and slider balls, ectetera. However the game seems playable.
to fix the font problem:
Open the terminal, input "sh winetricks", select "fontfix" and "fontsmooth-rgb".
Install it and the fonts should be right now
SatoXYN
It's me again. I'm running OSU under linux mint now. You should install corefonts, fontfix, fontsmooth-rgb and gdiplus. Without gdiplus there will be no messages in some boxes, just boxes with no text. If you use pulseaudio then you should run OSU with OSS or another sound system, it will go to segfault if you use alsa with pulseaudio. Try not to use hardware emulation. I'm running pure alsa now, with -40 audio offset, it's just fine.
SatoXYN
It's me again. Mouse acceleration in linux is absolutely another as in windows. I tried to configure mouse in linux with 1.0x in osu, because if I set anything but not 1.0x mouse got jitter or something like this, it's hard to explain. Finally I solved this. If you got mouse jitter on something but not 1.0x in osu, just set unlimiter framerate!
Crakila
@bagnz0r - Link is dead (http://bagnzor.org.pl/prepare-osu)
SatoXYN
Hahaha, don't try to run osu on wine 1.3. The old textures appearing on new ones.
osux
i'm tired trying even to launch main window! I got working Osume.exe, but osu!.exe even does not start to work.

logs:

wine

/media/ext/Program Files/osu!$ wine 'osu!.exe'
fixme:actctx:parse_manifest_buffer root element is L"asmv1:assembly", not <assembly>
fixme:sync:CreateMemoryResourceNotification (0) stub
err:ole:CoGetContextToken apartment not initialised
fixme:shell:URL_ParseUrl failed to parse L"System"
fixme:shell:URL_ParseUrl failed to parse L"System.Windows.Forms"
fixme:shell:URL_ParseUrl failed to parse L"System.Drawing"
fixme:shell:URL_ParseUrl failed to parse L"osu"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework"
fixme:shell:URL_ParseUrl failed to parse L"msvcm80"
fixme:shell:URL_ParseUrl failed to parse L"System.Runtime.Remoting"
fixme:process:SetProcessPriorityBoost (0x198,0): stub
fixme:shell:URL_ParseUrl failed to parse L"System.Drawing.resources"
fixme:shell:URL_ParseUrl failed to parse L"System.Drawing.resources"
Segmentation fault

mono
/media/ext/Program Files/osu!$ mono 'osu!.exe'

Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for <Module> ---> System.InvalidProgramException: Invalid IL code in #v.#u:#nj (): IL_0015: callvirt 0x0a000710


at <Module>..cctor () [0x00000]
--- End of inner exception stack trace ---
eMkay

osux wrote:

i'm tired trying even to launch main window! I got working Osume.exe, but osu!.exe even does not start to work.

logs:

wine

Code:
/media/ext/Program Files/osu!$ wine 'osu!.exe'
fixme:actctx:parse_manifest_buffer root element is L"asmv1:assembly", not <assembly>
fixme:sync:CreateMemoryResourceNotification (0) stub
err:ole:CoGetContextToken apartment not initialised
fixme:shell:URL_ParseUrl failed to parse L"System"
fixme:shell:URL_ParseUrl failed to parse L"System.Windows.Forms"
fixme:shell:URL_ParseUrl failed to parse L"System.Drawing"
fixme:shell:URL_ParseUrl failed to parse L"osu"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework"
fixme:shell:URL_ParseUrl failed to parse L"msvcm80"
fixme:shell:URL_ParseUrl failed to parse L"System.Runtime.Remoting"
fixme:process:SetProcessPriorityBoost (0x198,0): stub
fixme:shell:URL_ParseUrl failed to parse L"System.Drawing.resources"
fixme:shell:URL_ParseUrl failed to parse L"System.Drawing.resources"
Segmentation fault


mono
Code:
/media/ext/Program Files/osu!$ mono 'osu!.exe'

Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for <Module> ---> System.InvalidProgramException: Invalid IL code in #v.#u:#nj (): IL_0015: callvirt 0x0a000710


at <Module>..cctor () [0x00000]
--- End of inner exception stack trace ---
I've got exactly the same problem.
Newest Ubuntu LTS Version.
Other games run fine, but i have troubles with osu!
Can someone please help me/us?
Already tried with different wine versions but osu! always crashes.
SpacemanSpiff
I somehow got the whole thing to work on Arch Linux on i386. I have to switch to 64 later, so that's going to be fun and a half. I made sure I did the following:
I'll put whatever you might do in red and put in purple what I did in terms of command line.

Steps 1 and 2 are optional, but I would advise doing an update just for the sake of fps maximization.

1.Update your vid drivers to the max (this includes any commands to reconfigure your x-server. This requires a reboot to ensure the new x-settings are configured.
sudo (flavor repo system and - modifiers) (nvidia or ati named drivers)
sudo pacman -Sy nvidia

2. Run your commands to update the x.conf files with your new xserver drivers.
sudo nvidia-xconfig or sudo (whatever the ati one is)
sudo nvidia-xconfig

#####################################
REBOOT IF YOU UPDATED DURING STEP 1 & 2 for safety!
#####################################


3. Get latest wine
sudo (flavor repo system and - modifiers, such as apt-get install for Ubuntu) wine
sudo pacman -Sy wine (can do both at once, I did seperately when doing much trial and error)

4. Get latest winetricks
Either do the same as you did for wine, use an alternative system for your distro (like AUR for Arch Linux) or just get the source and manually apply it.
sudo pacman -Sy winetricks

5. Winetricks the following, and make sure you get gecko before dotnet20
sh winetricks gecko
sh winetricks dotnet20 fontfix fontsmooth-rgb gdiplus

sh winetricks gecko
sh winetricks dotnet20 fontfix fontsmooth-rgb gdiplus


6. Get a folder for pre-installed osu! (on a windows box or wherever else, I didn't want to deal with installation crap) and put it wherever you want to run osu! from.

7. Go into winecfg and default your system to pretend it's WinXP or add osu!.exe and osume.exe and make them run under WinXP. It's just one of the precautions to avoid an issue mentioned below, but it's only one way to make sure the problem doesn't arise.

8. Give osu! in wine a shot, preferably with aoss (get alsa-oss if you haven't, shame on you if that's the case!) and see how it runs. Any problems, crashes and errors might be caused by problems I listed below.

Everything works cleanly for me, no lag or stupid.

Some bugs I've encountered:

Error #1:
If you try to execute a wine script for osu! and anywhere in the path you run into permissions issues, you will always run into a Vista / 7 administration error and you will always crash. Period. Couple workarounds to this:
1. Make your script change to the osu! directory then execute wine.
2. Give your user read and write to everything in the osu! folder including the folder itself. Also give your user ownership (chmod and chown, I'll post the works for it if people want an explanation).


Error #2:
If you try changing your user file to opengl rather than d3d off the bat, I would advise going back if it fails to work like it fails for me. Also, try without the -opengl modifier too, that might fix the problem as well. I wouldn't know about opengl since it fails to work for me, but I'm just point out some simple fixes that might not jump to your mind at first.

Error #3:

Sound in the game is chopping up and I'm lagging in game! Halp!
I've hit this one a few times, including when I started it up, but I noticed quickly how this one comes up. Wine will favor ALSA or OSS, depending on what you run. I've found that the sound errors and how it's trying to emulate the sound for you can mess up osu! pretty badly. Just set sound to alsa, preferably

Hope this helps guys! Lemme know if I can help further.
eMkay
:o
I really don't know what i'm doing wrong.
Fresh installation of Ubuntu 10.04 LTS.
Newest wine ( wine1.3 )
corefonts, dotnet20, gdiplus, fontfix and fontsmooth-rgb via winetricks included in wine1.3 package.

But when i use wine to start the osu!installer.exe it just crashes after a time.

First error as far as i've seen is "System.IndexOutOfRangeException"

The people at appdb.winehq.com say that osu! works fine with wine1.2, corefonts, dotnet20 and ubuntu 10.04, but this didn't work for me -.-

Someone please help me?!
SpacemanSpiff

eMkay wrote:

:o
I really don't know what i'm doing wrong.
Fresh installation of Ubuntu 10.04 LTS.
Newest wine ( wine1.3 )
corefonts, dotnet20, gdiplus, fontfix and fontsmooth-rgb via winetricks included in wine1.3 package.

But when i use wine to start the osu!installer.exe it just crashes after a time.

First error as far as i've seen is "System.IndexOutOfRangeException"

The people at appdb.winehq.com say that osu! works fine with wine1.2, corefonts, dotnet20 and ubuntu 10.04, but this didn't work for me -.-

Someone please help me?!
Go get your latest drivers for your video card, run the x-config executable that comes with your drivers and reboot. Then do glxinfo | grep direct and prey it says:
direct rendering: yes

Also, I wouldn't advise using wine 1.3. Go uninstall tricks and wine and go get 1.2.3 (or whatever the latest STABLE is). I don't suggest running unstable because it sometimes has some serious conflicts with your x-configurations, even with the latest drivers.

Edit: Sorry about that, didn't put the command for glx testing in color. Make's things a bit more clear.
SatoXYN
Segfault because of PulseAudio, don't use it. Try swithing to OSS, and if no luck, uninstall PulseAudio and use pure Alsa.
SpacemanSpiff

SatoXYN wrote:

Segfault because of PulseAudio, don't use it. Try swithing to OSS, and if no luck, uninstall PulseAudio and use pure Alsa.
It's also a good idea to use OSS or ALSA simply because of some issues across programs and operations trying to use the same driver. I have to use aoss as a prefix for many operations because my system likes to only give sound to one program. Also like before, if you do this, tell winetricks to change to ALSA or OSS, don't use winecfg if you are familiar with it, my sound failed to work until I had winetricks force the change rather than winecfg. You will, however, need to use winecfg to confirm that sound works with the ''test sound'' button.

Alsp, I'm not sure if you have to tell config that osu!.exe or osume.exe has to run under Windows XP in order to avoid an issue I ran into before where it would say I would need to give administrator privileges. Those are minor compared to getting osu! up and running, though.
SatoXYN

mrmike503 wrote:

It's also a good idea to use OSS or ALSA simply because of some issues across programs and operations trying to use the same driver. I have to use aoss as a prefix for many operations because my system likes to only give sound to one program.
That's because you have no dmix and sound is not mixing.
eMkay
i still don't get it working -.-
Direct Rendering is enabled so no problem with that.
But it really seems that it's just the sound driver.
I already uninstalled PulseAudio using "sudo apt-get remove pulseaudio" and installed OSS instead.
I also defaulted sound to OSS and disabled ALSA.
I used winetricks to set sound to OSS and the sound test works fine
Well now osu! starts but i always get the Error Screen from osu! with that pippi thing.
SpacemanSpiff

eMkay wrote:

i still don't get it working -.-
Direct Rendering is enabled so no problem with that.
But it really seems that it's just the sound driver.
I already uninstalled PulseAudio using "sudo apt-get remove pulseaudio" and installed OSS instead.
I also defaulted sound to OSS and disabled ALSA.
I used winetricks to set sound to OSS and the sound test works fine
Well now osu! starts but i always get the Error Screen from osu! with that pippi thing.
Did you try ALSA instead? I don't know if your system automatically configured to your sound card, but maybe that needs to be updated too. I never have that issue because I don't get sound until I manually set it up.

Also thanks for the dmix tip sato, I think I've run into the issue even if dmix is set up. I had it happen before in Ubuntu when I used to use it. Arch has you set up everything manually, so I did what I knew best for a workaround. :lol:
show more
Please sign in to reply.

New reply