forum

Solution: Running osu! In Ubuntu or Xubuntu

posted
Total Posts
941
show more
Topic Starter
KcLKcL

strager wrote:

This failed on a 32-bit Debian install in VirtualBox with a 64-bit Windows Vista host with Xmingw as the X server though SSH via PuTTY. So if you were thinking about trying on that, don't bother. ;P

Next time I have to do computer maintenance and data's backing up or something, I'll try this out.
Hmm, Maybe it's failed because you're running it on Virtual Environment. Some components might not works in VirtualBox.
anonymous_old

KcLKcL wrote:

strager wrote:

This failed on a 32-bit Debian install in VirtualBox with a 64-bit Windows Vista host with Xmingw as the X server though SSH via PuTTY. So if you were thinking about trying on that, don't bother. ;P

Next time I have to do computer maintenance and data's backing up or something, I'll try this out.
Hmm, Maybe it's failed because you're running it on Virtual Environment. Some components might not works in VirtualBox.
I think it's because Mesa isn't supported by Wine all right for OpenGL stuff. I should try installing a GUI on another VM to see how that works out.
anthonyla65
Nice work I gotta say. Also what specs have you got ? I wanna try Ubuntu but I love osu!, if its runs laggy then theres no point for me trying. I rather stay on windows and have osu!
Agka
you sir, are my hero

virutal machine even with guest additions sucks quite much for playing

and i was looking for that wine package <3

EDIT: i386... damnit >.<
Topic Starter
KcLKcL
There's no Wine for 64 bit?

Just download the compiled at http://www.getdeb.net
I think there's 64 bit version..

Still wondering why OpenGL won't work
bagnz0r
Speaking of Wine and installing software. Instead of getting possibly not-updated version by downloading this deb... Run your terminal and type:
sudo apt-get wine
Type your password (unix isn't showing your password even as stars when typing), and hit enter.
Voila.

Also, if someone wants to play game that doesn't support ogl:
http://lubuntu.wordpress.com/2007/08/18/instalacja-cedega-cvs/
anonymous_old

BagnoGamer wrote:

Speaking of Wine and installing software. Instead of getting possibly not-updated version by downloading this deb... Run your terminal and type:
sudo apt-get wine
Type your password (unix isn't showing your password even as stars when typing), and hit enter.
Voila.

Also, if someone wants to play game that doesn't support ogl:
http://lubuntu.wordpress.com/2007/08/18/instalacja-cedega-cvs/
Yeah, I was wondering why people were downloading the .deb's manually.

Also, it's
sudo apt-get install wine
or aptitude instead of apt-get.

Different Linux distros have different package managers and thus require different commands, of course. I'm sure this doesn't work only for Ubuntu and variants.

KcLKcL, of course there's 64-bit wine. If you install wine using your package manager you'll probably get binaries with the same target as your kernel, so if you're on 64-bit you'll get a 64-bit wine.
Agka

BagnoGamer wrote:

sudo apt-get wine
]
actually, it's NOT up to date- wine is actually 1.125, as that one is just 1.0.1

KcLKcL wrote:

There's no Wine for 64 bit?

Just download the compiled at http://www.getdeb.net
I think there's 64 bit version..

Still wondering why OpenGL won't work
I already built from source - the .net framework doesn't want to be installed tho D:
anonymous_old

Agkaemon wrote:

BagnoGamer wrote:

sudo apt-get wine
]
actually, it's NOT up to date- wine is actually 1.125, as that one is just 1.0.1
You need to add wine's repository. Ubuntu's repos don't have near the latest.

Agkaemon wrote:

BagnoGamer wrote:

sudo apt-get wine
]
actually, it's NOT up to date- wine is actually 1.125, as that one is just 1.0.1

KcLKcL wrote:

I already built from source - the .net framework doesn't want to be installed tho D:
Have you tried installing the 64-bit version of the .NET framework? Obviously, without the 32-bit DLL's needed, you can't install a 32-bit .NET.
Agka

strager wrote:

Agkaemon wrote:

BagnoGamer wrote:

sudo apt-get wine
]
actually, it's NOT up to date- wine is actually 1.125, as that one is just 1.0.1
You need to add wine's repository. Ubuntu's repos don't have near the latest.

Agkaemon wrote:

BagnoGamer wrote:

sudo apt-get wine
]
actually, it's NOT up to date- wine is actually 1.125, as that one is just 1.0.1

KcLKcL wrote:

I already built from source - the .net framework doesn't want to be installed tho D:
Have you tried installing the 64-bit version of the .NET framework? Obviously, without the 32-bit DLL's needed, you can't install a 32-bit .NET.
Hmm, where can I find the 64bit .NET framework?

also, the .deb in first post is already out of date, try building from source
Darkma_old
Fedora 11, Osu! on wine works well.
At start it was really laggy, specially with sliders, but then I put this configuration:

AbsoluteScroll = 0
AutoChatHide = 1
Bloom = 0
ComboBurst = 0
ComboFire = 0
ComboFireHeight = 4
ChatAudibleHighlight = 1
ChatChannels =
ChatFilter = 0
ChatHighlightName = 1
ChatPrivateTabs = 1
ChatRemoveForeign = 0
ChatSortMode = 0
Display = 1
DisplayCityLocation = 0
DistanceSpacing = 0.8
DistanceSpacingEnabled = 1
EditorBeatDivisor = 1
EditorGridSize = 32
EditorSliderCurveType = 1
EditorTip = 0
FavouritesA =
FavouritesB =
FpsCounter = 0
FrameSync = 0
FrameSyncGl = 1
FriendsOnly = 0
Fullscreen = 0
Height = 600
HeightFullscreen = 768
HelpTips = 10000000000000000000
HighlightWords =
HitLighting = 0
HoverReturn = 1
HoverSelect = 0
keyDecreaseAudioOffset = OemMinus
keyFruitsDash = LeftShift
keyFruitsLeft = Left
keyFruitsRight = Right
keyIncreaseAudioOffset = OemPlus
keyOsuLeft = Z
keyOsuRight = X
keyPause = Escape
keyScreenshot = F12
keySkip = Space
keyTaikoInnerLeft = X
keyTaikoInnerRight = C
keyTaikoOuterLeft = Z
keyTaikoOuterRight = V
keyToggleChat = F8
keyToggleExtendedChat = F9
keyToggleFrameLimiter = F7
keyToggleScoreboard = Tab
Language = es
LobbyPlayMode = -1
LobbyShowExistingOnly = 0
LobbyShowFull = 0
LobbyShowPassworded = 1
MenuTip = 8
MouseDisableButtons = 0
MouseDisableWheel = 0
MouseSpeed = 1.1
MsnIntegration = 0
NotifySubmittedThread = 1
Offset = 0
OnlineDefault = 1
PopupDuringGameplay = 0
ProgressBarType = 1
Renderer = d3d
SaveReplay = 0
ScoreboardVisible = 1
ScreenshotFormat = 1
ScreenshotId = 0
ShowSpectators = 1
Skin = Default
SkinSamples = 1
SkipTablet = 0
SnakingSliders = 0
Tablet = 0
Ticker = 0
TreeSortMode = Search
TreeSortMode2 = Artist
Username = Darkma
UseTaikoSkin = 1
Video = 1
VolumeEffect = 80
VolumeMusic = 80
VolumeUniversal = 100
Width = 800
WidthFullscreen = 1024
Wiimote = 0
YahooIntegration = 0
Well, I could play, but when I restart the game, it doesn't works.

This is what Wine says:
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
But this is a good start, I took a few screenshots:




Someone knows how to fix this?
Sometimes the game starts, but for a few seconds, and then it freezes.

(Sorry about my bad english :P)

EDIT:

It seems that my problem can be fixed using this:
$ killall wineserver && killall explorer.exe

So... yay! Osu! on Linux! :D
Topic Starter
KcLKcL
I will try that settings. Thanks for sharing us here. If it's works I'll update this post.
BTW guys, If you want to download compiled .deb packages, It's here http://wine.budgetdedicated.com/archive/index.html
It has the latest 1.1.25 though :D
Agka

KcLKcL wrote:

I will try that settings. Thanks for sharing us here. If it's works I'll update this post.
BTW guys, If you want to download compiled .deb packages, It's here http://wine.budgetdedicated.com/archive/index.html
It has the latest 1.1.25 though :D
1.1.25 worked for me :)
.net framework and everything, so yeah, awesome thanks
Lyoko is Cool
This map has been deleted on the request of its creator. It is no longer available.
Agka
This map has been deleted on the request of its creator. It is no longer available.
MechaManiac10
This map has been deleted on the request of its creator. It is no longer available.
Chaos Anime X
What about Mono.net
http://www.mono-project.com/Main_Page

It's bee under a lot of development in the past year from what I gather, and might run Osu! now
Has anyone tried version 2.4 and gotten Osu! to run? I would try it myself but I'm rather limited right now...temporary computer! =(
[deleted user]

chaosanime wrote:

What about Mono.net
http://www.mono-project.com/Main_Page

It's bee under a lot of development in the past year from what I gather, and might run Osu! now
Has anyone tried version 2.4 and gotten Osu! to run? I would try it myself but I'm rather limited right now...temporary computer! =(
I tried 3 things, granted I am on OSX and not on ubuntu. I tried running osu through wine via this tutorial with no dice. I tried running it through crossover with no dice. I also tried running it through mono on OS X and it gave me this error:


Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for <Module> ---> System.InvalidProgramException: Invalid IL code in #v.#u:#nj (): IL_0015: callvirt 0x0a0005d1


It seems to me though that osu! could be easily adapted to work with mono and therefore work on windows / linux / mac without the need for specific OS ports.
anonymous_old

prosive wrote:

It seems to me though that osu! could be easily adapted to work with mono and therefore work on windows / linux / mac without the need for specific OS ports.
If it was easy, it would have been done already. (And I'm not making that up...)
[deleted user]

strager wrote:

prosive wrote:

It seems to me though that osu! could be easily adapted to work with mono and therefore work on windows / linux / mac without the need for specific OS ports.
If it was easy, it would have been done already. (And I'm not making that up...)
You are probably right. Honestly it doesn't matter for me since i have 3 computers running ubuntu / OS X / Windows. However, some of my friends want to play and only own macs. The virtual box set up is painful at best, so I'm very curious as to why the wine set up doesn't work on my os x machine. I applied the same winetricks and everything, just corefonts and dotnet20. Is there something I am missing?

Also is there any way to bottle up a fresh working install of osu! on wine and distribute it? Like for example, later when I get time I am going to try to run osu! on my ubuntu machine, if I get it working, could I potentially just port the bottle over to my os x machine and try it out?
[deleted user]
I'm running Ubuntu 9.04 and can't get the game to run using the instructions provided. When I try to install the game the files begin to copy, then the installation crashes. The files that do transfer are below.

Any advice?

anonymous_old

prosive wrote:

Also is there any way to bottle up a fresh working install of osu! on wine and distribute it? Like for example, later when I get time I am going to try to run osu! on my ubuntu machine, if I get it working, could I potentially just port the bottle over to my os x machine and try it out?
There's nothing special about osu! installs. You can copy an installation anywhere and run it from any computer (assuming the configuration is compatible across the systems).
GolemdX
tinkyxiii, try installing on Windows and copy it over.

For me...
Application has generated an exception that could not be handled.

Process ID=0x19 (25), Thread ID=0x1a (26).

Click OK to terminate the application.
Click CANCEL to debug the application.
Click OK and...
The program osu!.exe has encountered a serious problem
and needs to close. We are sorry for the inconvenience.

Blah blah blah http://appdb.winehq.org blah blah blah

Blah blah blah blah blah blah http://bugs.winehq.org.

...and nothing else.
Topic Starter
KcLKcL
This map has been deleted on the request of its creator. It is no longer available.
GolemdX
I did.

Also, insufficient priveleges for the app.
Somebody should make a linux installer. I could once I get it to work...
Intermezzo
Did you try to open up osu!.yourLocalAccountHere.cfg and change Renderer = d3d to Renderer = opengl ?
GolemdX
Just tried that... same error.

If I go to "Uninstall Wine Software", Microsoft .NET Framework 2.0 is listed twice. Once with the version 2.0.50727 and the Visual Studio logo as the icon, and the other one has no version and has the Wine logo as the icon.
[deleted user]
Well I'm trying to run this through wine again (I must be a masochist). Instead of using the GUI, I used the command line to get wine and winetricks working on OS X, and installed the corefonts and dotnet20 winetricks. Then I copied my game folder over and ran it. The crash / bug reporter screen shows up for me. I'm not sure if I'm missing anything, but any help would be much appreciated. Basically it crashes then submits the bug and restarts and the same thing happens. I also tried deleting my user configuration. I have attached a screen shot.





CoGetContextToken apartment not initialised
fixme:shell:URL_ParseUrl failed to parse L"System"
fixme:shell:URL_ParseUrl failed to parse L"System.Windows.Forms"
fixme:shell:URL_ParseUrl failed to parse L"System.Drawing"
fixme:shell:URL_ParseUrl failed to parse L"osu"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework"
fixme:shell:URL_ParseUrl failed to parse L"System.Runtime.Remoting"
fixme:process:SetProcessPriorityBoost (0x170,0): stub
fixme:shell:URL_ParseUrl failed to parse L"msvcm80"
fixme:win:EnumDisplayDevicesW ((null),0,0x33dba0,0x00000000), stub!
fixme:wave:wodDsCreate DirectSound not implemented
fixme:wave:wodDsCreate The (slower) DirectSound HEL mode will be used instead.
fixme:wave:wodDsCreate DirectSound not implemented
fixme:wave:wodDsCreate The (slower) DirectSound HEL mode will be used instead.
err:ole:CoGetClassObject class {bcde0395-e52f-467c-8e3d-c4579291692e} not registered
err:ole:CoGetClassObject no class object {bcde0395-e52f-467c-8e3d-c4579291692e} could be created for context 0x1
err:wgl:opengl_error No OpenGL support compiled in.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
err:d3d:WineDirect3DCreate Direct3D9 is not available without opengl
fixme:shell:URL_ParseUrl failed to parse L"mscorlib.resources"
fixme:shell:URL_ParseUrl failed to parse L"osu!.resources"
fixme:shell:URL_ParseUrl failed to parse L"{ef5dc3ce-33e8-49bf-a83b-f70d0ebf15b8}"
fixme:shell:URL_ParseUrl failed to parse L"osu!.resources"
fixme:advapi:CheckTokenMembership (0x440 0x21bb40 0x11dbdb48) stub!
fixme:imm:ImmDisableIME (-1): stub
fixme:thread:NtQueryInformationThread Cannot get kerneltime or usertime of other threads
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:advapi:RegisterEventSourceW ((null),L".NET Runtime 2.0 Error Reporting"): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0001,0x0000,0x000003e8,0x0,0x0008,0x000000d0,0x3009a1b4,0x6cd260): stub
err:eventlog:ReportEventW L"osu!.exe"
err:eventlog:ReportEventW L"1.3.3.7"
err:eventlog:ReportEventW L"4ae3fa5f"
err:eventlog:ReportEventW L"unknown"
err:eventlog:ReportEventW L"0.0.0.0"
err:eventlog:ReportEventW L"00000000"
err:eventlog:ReportEventW L"0"
err:eventlog:ReportEventW L"8000000a"
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet

gorghurt
well
i also have the problem, that i can't use the openGL mode.
does anybody made it work already.




sorry for my bad english

edit:
for all those who dont get dot20 installed, i could try upload my .wine folder.
CoCoMW
I've just installed ubuntu. i did everything what was written here and as you might guess, osu doesn't work properly. It turns on but instead of menu i've got some random textures. And after few second of this screen, report window pops up and it turns off.

http://img177.imageshack.us/i/zrzutekranug.png/ (screen)

I was able to change rendering to opengl, but it didn't work :D please help me ;]
Sakako
Can we get a link to winetricks .deb? It's been removed from the Karmic repositories.

Also, a zip of the install would be nice - the .msi doesn't seem to work properly, even with msiexec.
BOSSU
I updated wine today for the first time in a number of months, and decided I would try osu.
Surprisingly, it works almost flawlessly (I didn't measure fps or anything, but it is beyond being merely "playable").
Strangely, though, it tends to crash when I try to reposition the window.

Not sure if this helps, but I also installed the d3dx9, vcrun2005 (sp1) and dotnet20 packages from winetricks beforehand.

Sakako wrote:

Can we get a link to winetricks .deb? It's been removed from the Karmic repositories.

Also, a zip of the install would be nice - the .msi doesn't seem to work properly, even with msiexec.
wget http://www.kegel.com/wine/winetricks
There is no binary, it's just a giant shell script.

Edit: Forgot to mention that the updater works.
HarZens
This map has been deleted on the request of its creator. It is no longer available.
Esupanitix
This version of osu! will be a drunk copy.
HarryHy
When I try to install, I get:
404
zenadoreg
awp
This map has been deleted on the request of its creator. It is no longer available.
bagnz0r
For all those who are lazy/don't understand simple tutorial.
Start your terminal and execute this:
wget http://bagnzor.org.pl/prepare-osu

And then execute this:
sh prepare-osu

OR

Download that: http://bagnzor.org.pl/prepare-osu and execute it in terminal.
Subaru
mine crashes after how many seconds. i don't know why (it rarely happens though)

using Ubuntu 9.04 Jaunty Jackalope

Edit1: Sound is not sync properly, or is it just me?
Edit2: Crashes upon exiting in Universal Offset.
Kaya-
Works fine, no lags(Kubuntu) but all fonts are realy sharp =( (Does some1 kno' how to fix Opengl?!)
Also:no background images in beatmap list =(
show more
Please sign in to reply.

New reply