1. osu! forums
  2. osu!
  3. Development
show more
posted
Oh, nice, osu! works with wine.

Unless the user runs as su, prepend sudo to the apt-get.
posted
Well can someone test it?
On my computer it's very laggy when playing. So it's unplayable. I've set it at 800x600 and disabled all effects (even snaking sliders)

And yeah, I use Onboard VGA here, might try doing some tweaks on winecfg.

Edit: It's laggy when there's slider coming, when there's no slider, it's not laggy. Even with Snaking Sliders disabled it's laggy for me.
posted
...nice

Have you tried switching to OpenGl renderer?
posted
I tried to switch to OpenGL renderer on the Osu's settings menu. But after that, the game restarts and then it won't start until i delete the .cfg files.

Or should I run: wine osu.exe -OpenGL ?
posted
This map has been deleted on the request of its creator. It is no longer available.
posted
I will test at Ubuntu later on. Xubuntu lacks too many libraries and maybe it causes OpenGL isn't working.
Still downloading Ubuntu at 45kbps speed..LOL (Slow Internet at Indonesia lol)
posted
This map has been deleted on the request of its creator. It is no longer available.
posted

strager wrote:

This failed on a 32-bit Debian install in VirtualBox with a 64-bit Windows Vista host with Xmingw as the X server though SSH via PuTTY. So if you were thinking about trying on that, don't bother. ;P

Next time I have to do computer maintenance and data's backing up or something, I'll try this out.
Hmm, Maybe it's failed because you're running it on Virtual Environment. Some components might not works in VirtualBox.
posted

KcLKcL wrote:

strager wrote:

This failed on a 32-bit Debian install in VirtualBox with a 64-bit Windows Vista host with Xmingw as the X server though SSH via PuTTY. So if you were thinking about trying on that, don't bother. ;P

Next time I have to do computer maintenance and data's backing up or something, I'll try this out.
Hmm, Maybe it's failed because you're running it on Virtual Environment. Some components might not works in VirtualBox.
I think it's because Mesa isn't supported by Wine all right for OpenGL stuff. I should try installing a GUI on another VM to see how that works out.
posted
Nice work I gotta say. Also what specs have you got ? I wanna try Ubuntu but I love osu!, if its runs laggy then theres no point for me trying. I rather stay on windows and have osu!
posted
you sir, are my hero

virutal machine even with guest additions sucks quite much for playing

and i was looking for that wine package <3

EDIT: i386... damnit >.<
posted
There's no Wine for 64 bit?

Just download the compiled at http://www.getdeb.net
I think there's 64 bit version..

Still wondering why OpenGL won't work
posted
Speaking of Wine and installing software. Instead of getting possibly not-updated version by downloading this deb... Run your terminal and type:
sudo apt-get wine
Type your password (unix isn't showing your password even as stars when typing), and hit enter.
Voila.

Also, if someone wants to play game that doesn't support ogl:
http://lubuntu.wordpress.com/2007/08/18/instalacja-cedega-cvs/
posted

BagnoGamer wrote:

Speaking of Wine and installing software. Instead of getting possibly not-updated version by downloading this deb... Run your terminal and type:
sudo apt-get wine
Type your password (unix isn't showing your password even as stars when typing), and hit enter.
Voila.

Also, if someone wants to play game that doesn't support ogl:
http://lubuntu.wordpress.com/2007/08/18/instalacja-cedega-cvs/
Yeah, I was wondering why people were downloading the .deb's manually.

Also, it's
sudo apt-get install wine
or aptitude instead of apt-get.

Different Linux distros have different package managers and thus require different commands, of course. I'm sure this doesn't work only for Ubuntu and variants.

KcLKcL, of course there's 64-bit wine. If you install wine using your package manager you'll probably get binaries with the same target as your kernel, so if you're on 64-bit you'll get a 64-bit wine.
posted

BagnoGamer wrote:

sudo apt-get wine
]
actually, it's NOT up to date- wine is actually 1.125, as that one is just 1.0.1

KcLKcL wrote:

There's no Wine for 64 bit?

Just download the compiled at http://www.getdeb.net
I think there's 64 bit version..

Still wondering why OpenGL won't work
I already built from source - the .net framework doesn't want to be installed tho D:
posted

Agkaemon wrote:

BagnoGamer wrote:

sudo apt-get wine
]
actually, it's NOT up to date- wine is actually 1.125, as that one is just 1.0.1
You need to add wine's repository. Ubuntu's repos don't have near the latest.

Agkaemon wrote:

BagnoGamer wrote:

sudo apt-get wine
]
actually, it's NOT up to date- wine is actually 1.125, as that one is just 1.0.1

KcLKcL wrote:

I already built from source - the .net framework doesn't want to be installed tho D:
Have you tried installing the 64-bit version of the .NET framework? Obviously, without the 32-bit DLL's needed, you can't install a 32-bit .NET.
posted

strager wrote:

Agkaemon wrote:

BagnoGamer wrote:

sudo apt-get wine
]
actually, it's NOT up to date- wine is actually 1.125, as that one is just 1.0.1
You need to add wine's repository. Ubuntu's repos don't have near the latest.

Agkaemon wrote:

BagnoGamer wrote:

sudo apt-get wine
]
actually, it's NOT up to date- wine is actually 1.125, as that one is just 1.0.1

KcLKcL wrote:

I already built from source - the .net framework doesn't want to be installed tho D:
Have you tried installing the 64-bit version of the .NET framework? Obviously, without the 32-bit DLL's needed, you can't install a 32-bit .NET.
Hmm, where can I find the 64bit .NET framework?

also, the .deb in first post is already out of date, try building from source
posted
Fedora 11, Osu! on wine works well.
At start it was really laggy, specially with sliders, but then I put this configuration:

AbsoluteScroll = 0
AutoChatHide = 1
Bloom = 0
ComboBurst = 0
ComboFire = 0
ComboFireHeight = 4
ChatAudibleHighlight = 1
ChatChannels =
ChatFilter = 0
ChatHighlightName = 1
ChatPrivateTabs = 1
ChatRemoveForeign = 0
ChatSortMode = 0
Display = 1
DisplayCityLocation = 0
DistanceSpacing = 0.8
DistanceSpacingEnabled = 1
EditorBeatDivisor = 1
EditorGridSize = 32
EditorSliderCurveType = 1
EditorTip = 0
FavouritesA =
FavouritesB =
FpsCounter = 0
FrameSync = 0
FrameSyncGl = 1
FriendsOnly = 0
Fullscreen = 0
Height = 600
HeightFullscreen = 768
HelpTips = 10000000000000000000
HighlightWords =
HitLighting = 0
HoverReturn = 1
HoverSelect = 0
keyDecreaseAudioOffset = OemMinus
keyFruitsDash = LeftShift
keyFruitsLeft = Left
keyFruitsRight = Right
keyIncreaseAudioOffset = OemPlus
keyOsuLeft = Z
keyOsuRight = X
keyPause = Escape
keyScreenshot = F12
keySkip = Space
keyTaikoInnerLeft = X
keyTaikoInnerRight = C
keyTaikoOuterLeft = Z
keyTaikoOuterRight = V
keyToggleChat = F8
keyToggleExtendedChat = F9
keyToggleFrameLimiter = F7
keyToggleScoreboard = Tab
Language = es
LobbyPlayMode = -1
LobbyShowExistingOnly = 0
LobbyShowFull = 0
LobbyShowPassworded = 1
MenuTip = 8
MouseDisableButtons = 0
MouseDisableWheel = 0
MouseSpeed = 1.1
MsnIntegration = 0
NotifySubmittedThread = 1
Offset = 0
OnlineDefault = 1
PopupDuringGameplay = 0
ProgressBarType = 1
Renderer = d3d
SaveReplay = 0
ScoreboardVisible = 1
ScreenshotFormat = 1
ScreenshotId = 0
ShowSpectators = 1
Skin = Default
SkinSamples = 1
SkipTablet = 0
SnakingSliders = 0
Tablet = 0
Ticker = 0
TreeSortMode = Search
TreeSortMode2 = Artist
Username = Darkma
UseTaikoSkin = 1
Video = 1
VolumeEffect = 80
VolumeMusic = 80
VolumeUniversal = 100
Width = 800
WidthFullscreen = 1024
Wiimote = 0
YahooIntegration = 0
Well, I could play, but when I restart the game, it doesn't works.

This is what Wine says:
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
But this is a good start, I took a few screenshots:




Someone knows how to fix this?
Sometimes the game starts, but for a few seconds, and then it freezes.

(Sorry about my bad english :P)

EDIT:

It seems that my problem can be fixed using this:
$ killall wineserver && killall explorer.exe
So... yay! Osu! on Linux! :D
posted
I will try that settings. Thanks for sharing us here. If it's works I'll update this post.
BTW guys, If you want to download compiled .deb packages, It's here http://wine.budgetdedicated.com/archive/index.html
It has the latest 1.1.25 though :D
posted

KcLKcL wrote:

I will try that settings. Thanks for sharing us here. If it's works I'll update this post.
BTW guys, If you want to download compiled .deb packages, It's here http://wine.budgetdedicated.com/archive/index.html
It has the latest 1.1.25 though :D
1.1.25 worked for me :)
.net framework and everything, so yeah, awesome thanks
show more
Please sign in to reply.