Solution: Running osu! In Ubuntu or Xubuntu

posted
Total Posts
941
show more
Alysia
Does anyone have any tips on running osu! on GNOME/Kali Linux?
TinC
Hey, have mint kde x64, but osu client from playonlinux app run only in x32. How can I fix this and run x64 version? Teach me, senpai.
marshallracer

TinC wrote:

Hey, have mint kde x64, but osu client from playonlinux app run only in x32. How can I fix this and run x64 version? Teach me, senpai.
Basically, there's a in-depth, up-to-date guide over here
There are sections on creating 32-Bit Wine prefixes for various conditions such as either using pre-existing or self-compiled wine versions
If you want to get it working as easily as possible I guess taking the PlayOnLinux route is your best bet but you're given various options (papa bless Franc[e]sco for all of his efforts of making and updating his guide)
Stray Lamb2
I've been playing on Linux Xubuntu 16.04 in PlayOnLinux for a month or two now, stable fps, no tearing, same latency as windows, minor visual issues with settings side panel and non-latin letters. If you check my latest scores, given my skill level, it is the same as my pre-linux scores. So, with that as a metric, you could say it is the same exact experience.

How I got it running is simple:
- Make a new PoL drive (x32), with wine 2.0-rc3-staging (x32).

- Configure->Miscellaneous->Open a shell

- Enter the following (one at a time) :

Install newest winetricks:
  wget  https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
chmod +x winetricks

Install vcrun2015
sh winetricks vcrun2015

- Go to the "Install components" tab, install dotnet40

- Miscellaneous tab once again, "Run a .exe file in this virtual drive"

- Run your osu! installer

- Play the game

Hope it works for you too, didn't post up until now to test functionality.
CodeNameT1M
just found this post and i also got osu! to run, but it doesn't connect to Bancho

osu 20170616 (latest)
wine 2.11
manjaro linux 17.0.2
dotnet 4.5 installed

if someone else had this problem and know how to fix that i would appreciate it if you help me ^^
marshallracer

DJT1M wrote:

just found this post and i also got osu! to run, but it doesn't connect to Bancho

osu 20170616 (latest)
wine 2.11
manjaro linux 17.0.2
dotnet 4.5 installed

if someone else had this problem and know how to fix that i would appreciate it if you help me ^^
From this Thread

SanteriP wrote:

Fixed it by installing lib32-gnutls and lib32-gnutls26 (not sure which one because I installed both at once, lol). Also installed libgnutls. The game is running! Wonderful.
Ambrew
Hi, Does this work on Lubuntu 15.04 Vivid on a i386 (32-bit) architecture? Thanks!

EDIT: Looking through the guide I came across this...

6. Download osume.exe
Terminal > wget http://osu.ppy.sh/release/osume.exe
This link leads to an HTTP 404 Not Found Error. Can someone post an updated link?
marshallracer

Ambrew wrote:

This link leads to an HTTP 404 Not Found Error. Can someone post an updated link?
I would instead follow the guide on t/367783
It's up-to-date and gives you varying ways to install osu


To this date I wonder why the other thread isn't stickied yet >:(
roblox
Could you make a version for Lubuntu?? Thanks :)
TheRealVinite
On osu! Updater it says ‘An error occurred! Please check your internet connection.’ How do I fix this problem?
Kazutoy
works fine on debian
gansta
you internet or wifi is slow :shock: ? :D;)
kiran
"An error occurred! Please check your internet connection" while installing osu
Stray Lamb2
@kiran install lib32nss-mdns. Wine has some issues with net connection while it isn't installed.
So, open a terminal and (assuming you've got a debian/ubuntu/mint distro) type
sudo apt install lib32nss-mdns
kiran

Stray Lamb2 wrote:

@kiran install lib32nss-mdns. Wine has some issues with net connection while it isn't installed.
So, open a terminal and (assuming you've got a debian/ubuntu/mint distro) type
sudo apt install lib32nss-mdns
still the same -> this is on debian
on ubuntu osu updater keeps restarting over and over again
Kilo-Five
>~< I broke it...

kilo-five@Kilo-Five-Base ~ $ WINEARCH=win32 winecfg
wine: WINEARCH set to win32 but '/home/kilo-five/.wine' is a 64-bit installation.
kilo-five@Kilo-Five-Base ~ $ winetricks dotnet20
The program 'winetricks' is currently not installed. You can install it by typing:
sudo apt install winetricks
kilo-five@Kilo-Five-Base ~ $ sudo apt install winetricks
[sudo] password for kilo-five:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
winetricks
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 132 kB of archives.
After this operation, 792 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu xenial/universe amd64 winetricks all 0.0+20141009+svn1208-2ubuntu1 [132 kB]
Fetched 132 kB in 2s (60.1 kB/s)
Selecting previously unselected package winetricks.
(Reading database ... 211989 files and directories currently installed.)
Preparing to unpack .../winetricks_0.0+20141009+svn1208-2ubuntu1_all.deb ...
Unpacking winetricks (0.0+20141009+svn1208-2ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22+linuxmint1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up winetricks (0.0+20141009+svn1208-2ubuntu1) ...
kilo-five@Kilo-Five-Base ~ $ winetricks dotnet20
------------------------------------------------------
You are using a 64-bit WINEPREFIX. If you encounter problems, please retest in a clean 32-bit WINEPREFIX before reporting a bug.
------------------------------------------------------
Executing w_do_call dotnet20
Executing load_dotnet20
Executing mkdir -p /home/kilo-five/.cache/winetricks/dotnet20
Downloading http://download.lenovo.com/ibmdl/pub/pc/pccbbs/thinkvantage_en/dotnetfx.exe to /home/kilo-five/.cache/winetricks/dotnet20
--2018-05-24 11:17:22-- http://download.lenovo.com/ibmdl/pub/pc/pccbbs/thinkvantage_en/dotnetfx.exe
Resolving download.lenovo.com (download.lenovo.com)... 23.205.215.148
Connecting to download.lenovo.com (download.lenovo.com)|23.205.215.148|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://download.lenovo.com/ibmdl/pub/pc/pccbbs/thinkvantage_en/dotnetfx.exe [following]
--2018-05-24 11:17:25-- https://download.lenovo.com/ibmdl/pub/pc/pccbbs/thinkvantage_en/dotnetfx.exe
Connecting to download.lenovo.com (download.lenovo.com)|23.205.215.148|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 23510720 (22M) [application/octet-stream]
Saving to: ‘dotnetfx.exe’

dotnetfx.exe 100%[===================>] 22.42M 220KB/s in 95s

2018-05-24 11:19:01 (241 KB/s) - ‘dotnetfx.exe’ saved [23510720/23510720]

Executing w_do_call remove_mono
Executing load_remove_mono
------------------------------------------------------
Mono does not appear to be installed.
------------------------------------------------------
Executing w_do_call fontfix
Executing load_fontfix
Setting Windows version to win2k
Executing winetricks_early_wine regedit C:\windows\Temp\_dotnet20\set-winver.reg
------------------------------------------------------
Working around wine bug 34803
------------------------------------------------------
DELETE - HKLM\Software\Microsoft\.NETFramework\v2.0.50727\SBSDisabled (null) 0 0 0
Error: The system was unable to find the specified registry key or value
Current wine does not have wine bug 30845, so not applying workaround
Executing wine dotnetfx.exe
fixme:advapi:DecryptFileA ("C:\\users\\kilo-five\\Temp\\IXP000.TMP\\", 00000000): stub
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:advapi:LsaOpenPolicy ((null),0x33f2cc,0x00000001,0x33f2c0) stub
fixme:advapi:LsaClose (0xcafe) stub
------------------------------------------------------
Note: command 'wine dotnetfx.exe' returned status 66. Aborting.
------------------------------------------------------
kilo-five@Kilo-Five-Base ~ $ WINEARCH=win32 winecfg
wine: WINEARCH set to win32 but '/home/kilo-five/.wine' is a 64-bit installation.
kilo-five@Kilo-Five-Base ~ $
Forefront
Can someone check my guide out? Most of the people I've shown it to says that it works for them all the time. I also did Japanese fonts, gdiplus and etc so there's no graphical glitches.

Link: https://osu.ppy.sh/community/forums/topics/794952
JustShiningStar
--2019-10-31 11:07:58-- http://osu.ppy.sh/release/osume.exe
Resolving osu.ppy.sh (osu.ppy.sh)... 104.20.52.28, 104.20.51.28, 2606:4700:10::6814:331c, ...
Connecting to osu.ppy.sh (osu.ppy.sh)|104.20.52.28|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2019-10-31 11:07:58 ERROR 404: Not Found.
if i try to get osume
- Marco -
osume was the old osu!updater, you should use the new installer https://m1.ppy.sh/r/osu!install.exe
LinkTFox
Alrighty, i'm a bored person who can't use my pc is using the schools chromebook, is there a way to run it here? It's a Lenovo 300e, i'm very bored LUL



~Link
Please sign in to reply.

New reply