[Archived] New Build causes input lag to an unplayable level.

posted
Total Posts
12
Topic Starter
Azer
Okay, I've been playing with these exact settings for months now this recent build causes a good amount of general input lag (I'd say around 150ms), whether it's a pen tap, a mouse click or a keyboard tap they are all affected and in the end render the game unplayable when you've been used to having no lag for an extremely long time. Note that I had no noticable lag on other games such as Team Fortress 2, Starcraft 2 and League of Legends.
This happens with both openGL and DirectX.

Build:

Razer Naga Molten
Bamboo CTH-470
Generic Nexxtech keyboard (I don't use it in game)
GameCon 780 Headset recieved today.

Windows 7 64bit
Geforce GTS 450
AMD Athlon II Quadcore 3.0GHz


Come to think about it, it could also potentially be caused by installing my headset drivers as there was no input lag prior to doing that.
In other words,
Previous osu! build and no headset drivers = No input lag
New osu! build and headset drivers = input lag
Not sure which one is the cause but I'm curious if I'm the only one with a similar problem.


EDIT: If someone could provide me access to an earlier build so I could test my drivers and potentially be able to play that would be great.
peppy
Nothing has changed at this end. Please try restarting your PC.
Topic Starter
Azer
It didn't change anything.

Addional note, I disable Windows Aero with OBS.
peppy
Have you tried running without OBS? What kind of input lag is this? Just mosue? Just keyboard?
Topic Starter
Azer
Without OBS it's even worse, I'd say it's now hovering around 200ms input lag

The actual cursor movement is fine, the lag problem is the clicks.
I currently use a tablet to move the cursor around and a mouse in my left hand to click.

The mouse clicks are delayed
The pen taps are delayed
Also, this keyboard is so old and cheap it also has a hefty about of lag itself, so I don't use it. But, I've tried it and the lag also affects this.
Again, this doesn't seem to happen anywhere else.
peppy
Sounds like something else on your system is capturing keyboard input at a global level. Shut down any "driver" apps, any helper apps etc. and see if it helps. Also avoid setting the frame limiter to unlimited.
RBRat3

Azer wrote:

It didn't change anything.

Addional note, I disable Windows Aero with OBS.
If you don't want composition with osu! just set it to disable from the compatibility tab in properties, Using OBS to do that is a bit out of the way.

Topic Starter
Azer
I looked around processes and I didn't really find such a thing. My frame limiter has always been on 120fps.

Also, I stream the majority of the time I play, so having OBS up has just become a normality now.
peppy
Have you tried playing without your tablet connected?
Topic Starter
Azer
Just did, no difference.
Topic Starter
Azer
actually, I'm not sure. Right now I'm trying to test it by playing full mouse and I'm not used to the timing to this since this mouse was usually in my left hand, I still don't think it helped though.
I disabled my headset drivers and theres no difference either.
Topic Starter
Azer
I'd love access to a previous build to test if it works properly.
Please sign in to reply.

New reply