Lag in User panel (F9) [confirmed] [invalid]

posted
Total Posts
16
Topic Starter
TheAussie
Explain the issue you are having:


Fps i usually get http://puu.sh/32Z2L.png

Fps with user panel open http://puu.sh/32Z3Z.png it can sometimes get lower i know 60 fps doesn't seem like lagg when spectating someone and i open userpanel it drops to 32 FPS.. why does this happen? i would like to know..


osu! build: b20130513
CPU: Core i5-650
GPU: GTX660
OS: Windows 7 Home Premium (64bit)
Lust
Try using an fps limiter or switching to opengl
TheVileOne
It's probably not osu's fault. How many resources get used when you access the userpanel? It's likely something stupid in entirely unnecessary running in the background causing this.
RBRat3
There are several reasons why this may happen, First thing that comes to mind is GPU power states kicking down depending on usage.

This is may be controlled by the driver, hardware onboard, and or programming of the game or both like for example a frame limiter on the user panel which causes the gpu power states to kick due to lack of usage (which I do believe is actually implemented for chat & userpanel when shown coulda sworn I saw it months ago in the changelog).


edit: eeeyup
Topic Starter
TheAussie

Side Pocket wrote:

Try using an fps limiter or switching to opengl
why would i switch to opengl?
Topic Starter
TheAussie

RBRat3 wrote:

There are several reasons why this may happen, First thing that comes to mind is GPU power states kicking down depending on usage.

This is may be controlled by the driver, hardware onboard, and or programming of the game or both like for example a frame limiter on the user panel which causes the gpu power states to kick due to lack of usage (which I do believe is actually implemented for chat & userpanel when shown coulda sworn I saw it months ago in the changelog).


edit: eeeyup
i done what you showed in these pictures and it doesnt drop at all lol


but does when i click out of osu! and back in of course.

drops to like 810 MHz but doesnt explain why only 60 fps that speed i get around 124 FPS lol
RBRat3
Welp it seems you'll just have to chalk it up to the GPU getting kicked in the dick with a frame limiter on when spectating with the panel up, Unlimited equivalent would be something along the lines of 1k > 500 versus 120 > 60
MillhioreF
I get a rather major FPS drop too when I set the userpanel list to "All" (500fps -> 45 fps) I think osu! has a hard time handling several thousand userpanels at once.
RBRat3
Ideally offscreen objects should be culled/clipped from the renderer (I would hope they are). Unfortunately I cant confirm whether they are or not so I cant answer to the rendering absolutely every user panel at once.
lolcubes
I can confirm this too. Generally I run at ~800 fps when playing/spectating, but opening the user panel drops me to 50 or so.
Actually, even opening the chat window drops it heavily as well, but not below 100 though.

I run an AMD PII 965@3.6GHz currently with a gtx 460 1GB and my drivers are up to date as well.

Note that these differences are so drastic in windowed mode only, in fullscreen it's not as drastic, so my guess is that it might have something to do with the windowed mode (I run the game at 1366x768 windowed).
TheVileOne
I tested this with my normal 800 x 600 window. I got 200 FPS normally and just opening the chat panel without the usergroups shown removes 75 FPS. It goes down to 125 and open userpanels with Friends tab removes 10-20 FPS. It hovers around 110-115 FPS. Setting it to All brings it down to 25 FPS.
Oinari-sama
Eh I thought it's actually a good thing? Since it lowers energy usage?

The question here is whether the User Panel really lag though. For my system, even with the reduced fps it feels quite smooth when browsing the user panel. Does it actually feel laggy on your systems?

I only have mediocre internet speed so bancho connection plays a more important limiting factor for me.
peppy
Is this a recent thing? I believe I may have broken it with one of the recent changes.

And acually, testing on the latest build I don't drop below 100fps. Which seems fine?
RBRat3

peppy wrote:

Is this a recent thing? I believe I may have broken it with one of the recent changes.
Been like that since the limiter went in place for the chat and userpanel (not sure how far it dropped before that).
I never had any problems with it tho, not something I perceive as lag it's just a drop in FPS lower than whats suppose to be limited.

Top post is kinda confusing but I think the concern is the drop while spectating with the panel up. (Correct me if im wrong)
lolcubes

RBRat3 wrote:

Top post is kinda confusing but I think the concern is the drop while spectating with the panel up. (Correct me if im wrong)
My report at least.
Standard doesn't look that bad, but taiko and mania are a pain to watch with the chat brought up. It's like, all the notes are suffering from periodic spasm attacks.
peppy
I don't think this is actually an issue. The performance on that screen is still well within a usable range. Even on slow PCs.
Please sign in to reply.

New reply