1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
Hey i have a problem with my osu!
My Laptop with win7 OS and DirectX11 doesn't support to open osu! with directx mode like this


I realized that Direct Draw and Direct 3D unvailable then tought that caused it
i have tried to search that but i still can't find it
and i have tried to re-install the driectx but it's nothing
How i can fix it ? :(
posted
Seems like you don't have drivers for your GPU. Try googling your laptop model, and downloading drivers for graphic card.
posted

Marcin wrote:

Seems like you don't have drivers for your GPU. Try googling your laptop model, and downloading drivers for graphic card.
it is "SiS VGA driver" am i right?
posted
Open osu!, and hold the Shift keyboard key while it is loading. Choose to use OpenGL when a window asks if you want to.
posted

Full Tablet wrote:

Open osu!, and hold the Shift keyboard key while it is loading. Choose to use OpenGL when a window asks if you want to.
but OpenGL mode it's so laggy i don't like that :(
are you know the tips for OpenGL to perform like DirectX ?
posted
Integrated SiS GPUs are very low-end, they don't support DirectX completely.

OpenGL is generally more laggy than DirectX, but it is more compatible.

Things you can try:
- Disable all visual settings in the game options.
- Play with low resolution, and fullscreen.
- Set frame limiter to about ~140fps or lower. (or use vsync if it causes problems, but the game is near unplayable with it...). To change it you have to edit the config file on the osu! folder with a text editor.
- Disable all unneeded background processes. You can use Game Booster for this (it disables some processes while playing the game).
posted

Full Tablet wrote:

Integrated SiS GPUs are very low-end, they don't support DirectX completely.

OpenGL is generally more laggy than DirectX, but it is more compatible.

Things you can try:
- Disable all visual settings in the game options.
- Play with low resolution, and fullscreen.
- Set frame limiter to about ~140fps or lower. (or use vsync if it causes problems, but the game is near unplayable with it...). To change it you have to edit the config file on the osu! folder with a text editor.
- Disable all unneeded background processes. You can use Game Booster for this (it disables some processes while playing the game).
ok thanks :D but disable all visual setting in game option,where ?
posted

I meant this, disable everything there.
posted
Thanks :D
Please sign in to reply.