1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
osu! runs fine. It's very smooth (120 FPS) but when I move my mouse it becomes really lag (1-10 FPS !!!!).
Never got this problem before a last few updates. It works perfectly fine last month !!

I use DirectX (tried using OpenGL but it became worse), Frame limiter at 120 (tried all of them) and I even tried disable every special effect.

How to fix this problem ? I searched the forums for hours but no answers.

Win7 Ultimate 64bit
CPU: Intel Core i5 3.70 GHz
GPU: AMD 6790 with memory of 1024 MB
RAM: 8 GB
posted
Does it only happen in osu!?
Turn off every program running in background, and try again.
posted
Yes, only in osu!
I can play any other games just fine but why only osu! is getting lag?

How do I close background programs ?
posted
What mouse do you use? Do you have an other mouse that you can try to see if the problem go away?
posted
I use Logitech Optical Gaming Mouse G400. I don't have any other mouses that still work.
And I only got this problem WAY after I bought this mouse.

It seems the lag is random. I started osu! again and found no lag. This has happened before. I thought the problem is solved but another day it came back.
posted
Just tried a google search and there are talks that graphic drivers may be the problem so try updating it http://support.amd.com/us/gpudownload/w ... sta64.aspx.

You say the lag disappeared, can you tell me what you were doing in between when the problem appeared, and when the problem disappeared? Also, when does the lag normally happen? Right after a computer start? Or just plain random? Lastly, how long does it lag for? If you stop moving your mouse, does the lag go away instantly?
posted
I already updated graphic driver to the latest version (13.1)

I didn't do anything when playing. No copying, no converting, no downloading and no other programs running. The lag just come and go.
It's plain random. From starting my computer to shutting down in a span of 5 - 10 hours.
And if I stop moving my mouse then the lag will disappear like it never existed.
posted
Maybe you can try the next time you lag to open task manager and see if your cpu usage is 100%. Then see if anything is hogging the resources.

Just making sure, you can alt tab and use the computer just fine or are you forced to close osu!? When moving mouse, is the mouse movement smooth or does both mouse and osu! lag. Are you playing full screen or windowed mode? Try borderless windowed mode if you use full screen (set osu! to your monitor native resolution and disable full screen).

Perhaps lowering the report rate (GHz) of your mouse can help. Download this http://www.logitech.com/en-us/support/o ... 40_x64.exe and adjust the settings.

Still need more information to tell what the problem is. It seems to me like something is causing cpu usage to be very high, and as moving the mouse require cpu power, this cause your cpu not being able to keep up and lag. Reducing the polling/report rate may help with this, but your cpu is quite good so I doubt this.
posted
I tried star task manager and exit fullscreen to windowed mode at the same time.
The CPU usage doesn't rise up when I move the mouse in osu! It's perfectly normal. Oh, I tried that borderless thing too. Nothing works.
both mouse and osu! are lagging.

I've already re-installed it but it's still the same.

I'm a hardcore gamer too. Every time I have problems with the game, I can often fix it. But RAGE and osu! just doesn't work properly. ha ha

Just hope that when I start osu! agian, there'll be no lag.
posted
Try downgrading/upgrading to beta drivers.

First, use this uninstall application http://sites.amd.com/US/GAME/DOWNLOADS/ ... ility.aspx

Then download an older version http://support.amd.com/us/gpudownload/w ... sta64.aspx (don't worry that it say vista, vista, 7 and 8 uses the same drivers).

Or try upgrading to the latest beta drivers found here http://support.amd.com/us/kbarticles/Pa ... river.aspx.

Make sure to always run the uninstall application before trying a different driver if the lag still persist.
posted
At first it's just osu! but now with all games. I played other games on yesterday just fine too.

But now it's solved. The problem is report rate of my mouse being set to 500 Hz.
I set it to 125 Hz and that solved everything.

Thanks everyone for providing great and really useful advices.
posted
I have a Logitech G400s and the same thing is happening. How did you manage to change you Polling rate?

pretty_odddd wrote:

osu! runs fine. It's very smooth (120 FPS) but when I move my mouse it becomes really lag (1-10 FPS !!!!).
Never got this problem before a last few updates. It works perfectly fine last month !!

I use DirectX (tried using OpenGL but it became worse), Frame limiter at 120 (tried all of them) and I even tried disable every special effect.

How to fix this problem ? I searched the forums for hours but no answers.

Win7 Ultimate 64bit
CPU: Intel Core i5 3.70 GHz
GPU: AMD 6790 with memory of 1024 MB
RAM: 8 GB
I have a Logitech G400s and the same thing is happening to me. How did you manage to change your polling rate? Thanks :)
posted
Just why. Why did you bump a 2 year old resolved thread?
Please make a seperate thread for your problem, thank you.
posted
might not be enough wattage to your computer. which explains why lowering your pooling rate works for some people. Try plugging your computer into a different outlet, or not using a multi-outlet power-surge protecter. Hopefully this saves someone time.
posted
Please don't bump 5 year old resolved threads.
Please sign in to reply.