User avatar
osu! Alumni
12,353 posts
Offline
This seems to be among the most popular subboards of the forum, and I've been doing a bit of poking around it to discover that in a fair number of threads, a common reply has been "can you provide more details?" or "this was already resolved in this thread/download page" so I thought, to help expediate the bug reporting/troubleshooting process, perhaps some guidelines for reporting an issue are in order.

I am still very new to this forum so everything here should be taken with a grain of salt, and a good chunk of this post is regurgitated from other replies.. But without further adieu...



Reporting an issue

Step one: Requirements
Check to see if you're missing something. A good number of issues have been a result of a .Net Framework error, which should not be an issue at all if you've taken a close look at the System Requirements page. For those of you running any Windows environment, you can generally find most of these details by right-clicking your "My Computer" (or just "Computer" for Vista users) and selecting Properties from the mouse menu. If you're running Linux and don't know what you're doing...no, just...no. That doesn't happen. Another common issue has to do with videocards (DirectX specifically), already outlined in detail in phill's thread.

Step two: Updates
Check to see if you have the latest version of osu!. This is obvious. Just run the updater.

Also make sure all of your hardware drivers are up to date. The latest version of most GPU/Sound cards/other things can be found on the manufacturer's website. Failing that, you can just run a google search of your hardware model number and include "driver" in the search. It's pretty easy to find driver updates.

Step three: Distro
If you're totally kosher with the above two steps, there's a good chance the problem you're having has to do with either the way your Operating System handles things, or better yet the problem has something to do with your machine specifically. Since most of us are pretty bad at ESP and/or clairvoyance, you'll save yourself some out-of-comission time by providing your system specs in your original post. While saying "I run XP" is a good start, don't forget to specify the service pack, and whether it's home/professional etc. I know Vista has an entire army of flavours, and any issue you're having may be due to your specific distro. If not, we continue onward to the next step...

Step four: Environment
In the event that you've made it through the first three steps smelling like roses, well...It's likely got to do with your computer's environment. I am, for the most part, at a loss here and it'll be up to the guardian angels of the development team to help you, because chances are, there are background processes running on your machine that are somehow interfering with osu!. I don't know how to help in this situation. All I can advise is, close down/suspend/end every non-critical process on your machine before loading osu! and see if that solves the problem. Also, if you are having connection-specific issues, disable your firewall/internet security temporarily to see if it helps.

Step Five: FAQ~on...PAAAAAAAAANCH~!!!
If something's still wrong, read the FAQ. From this day forth, if you're having a problem that is solved by reading the FAQ and following the FAQ's instructions, you and I will never be friends. Do you want that?

Step Six: The End of the Void
Run around flailing your arms like a little girl.

Step Seven: Making the Formal Bug Report (Summary)
Once you're out of breath after step 6, it's time to post your error. The first thing you should do is run a search query in the Bug Reports forum searching a few keywords relating to your error. Make sure your error is unique before you post a new thread about it. If it's not unique, read the thread, and post in there if necessary, otherwise you'll have to make a new thread. If you have to make a new thread, make the title descriptive.

On to making the actual post. Here's what you should be posting, in no particular order:

  • osu! build version (this can be located at the top-right of your options window, as shown in this picture
  • System/OS base specifications (these can be easily found in System Information - easily accessible by Windows 7 and Vista users by simply typing 'system information' into the taskbar search - XP users will have to find it in Administrative Tools in the Control Panel - after you have that open, click OS name then shift-click the bottom most entry and hit Ctrl+C (picture))
  • If the problem is graphics oriented, please include a dxdiag dump (type 'dxdiag' into Run or the taskbar search for W7/Vista users) as a .txt file attached to the post (even if you are using OGL this provides useful information about your graphics card - picture- click 'Save All Information' and include the .txt file which it produces)
  • How exactly you discovered the bug with clear instructions on how to replicate it - include pictures if possible and any error messages you may have received - these are EXTREMELY important to the process, if we cannot replicate the problem, we can't even begin to fix it!

Make your post here


Troubleshooting Common Issues
I've decided to start updating this thread with easily rectified problems that are being encountered so I can stop being a useless-input whore in the Bug Reports board. Let's get started.

Initialization Error
You didn't read the System Requirements from the Downloads page, did you? Get the .NET Framework and try again.

Game returns to title screen on song selection
Downloads Page wrote:
Download some beatmaps from the beatmap listing (or visit the forum for unofficial submissions) and place in the songs/ directory. IE USERS: The beatmaps will download as zip files - DO NOT EXTRACT these - simply place them in your Songs folder intact!


Simply put, you want your song.osz file to be sitting in the osu!/Songs/ directory. No "extract here" is necessary. Just put the .osz file in the songs folder. The program does the rest of the work.

osume.exe checks for updates endlessly
peppy wrote:
Please check your Internet Explorer security settings - make sure you don't have downloads blocked at all. This can usually be done by opening IE and going to:

Tools > Internet Options > Security

Click "Default Level"
Make sure the metre is set to Medium security.

Make sure you don't have any firewall/internet security software blocking the updater. If you do, try temporarily disabling.


By the way, IRC is a pretty good resource for instant assistance. Usually.

This post will be updated periodically as I continue to make a fool of myself.

AUTHOR'S FOOTNOTE: while I don't object to the amount of PMs I receive as a result of this thread, when PMing bugs, either send them directly to peppy or include peppy in the recipients list. I do what I can to troubleshoot issues sent by PM, however, I have coded a total of zero components of the program. Anything to do with implementation issues is all peppy. He knows the code, I don't. If you want a useful answer, I may not be the best for it
Last edited by MillhioreF on , edited 1 time in total.
retired
ImageImage
Twally Spocks is best pony ♥
Proud user of Etna Sliders.

You'll never pierce my admintium armour.
User avatar
17,579 posts
Offline
Awesome post. I made a few small edits, and will sticky it for now. Let's call this a WIP. Thanks for taking the initiative.
User avatar
osu! Alumni
263 posts
Offline
edited some typos and basked in the sheer brillance that is the thread ;)
User avatar
osu! Alumni
3,092 posts
Offline
Swapped requirements and update around, since the updater won't run without the .NET Framework.
User avatar
osu! Alumni
1,017 posts
Offline
This map has been deleted on the request of its creator. It is no longer available.
Image
User avatar
osu! Alumni
12,353 posts
Offline
Some of that information was already there, but I elaborated/collected it into Step 6. Also updated Step 2.
ImageImage
Twally Spocks is best pony ♥
Proud user of Etna Sliders.

You'll never pierce my admintium armour.
User avatar
17,579 posts
Offline
This map has been deleted on the request of its creator. It is no longer available.
User avatar
osu! Alumni
1,017 posts
Offline
awp wrote:
hey guys should I lock this thread and then clean it up or something

YES

awpEDIT: Cleaned thread up. Leaving in the two posts between Kipi and peppy because I found peppy's response hilarious.

For safety I'll leave the thread locked until there is a reason to unlock it ??? Also left in moderator recommendations/updates for I guess no legitimate reason.
Image
User avatar
osu! Alumni
3,289 posts
Offline
A very quick edit: expanded on the 'what you should post' section a great deal and included pretty, pretty pictures.

That is all.
Locked 10 posts

Users browsing this forum: None


Jump to: